summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreveryx2023-06-27 11:05:33 +0800
committereveryx2023-06-27 11:06:03 +0800
commit1f9378837ff644b92ae9472ca7c3e4e74b3860cb (patch)
treedeb457932df43eb7a73fb6cc2c6794cb2cf9ef8e
downloadaur-1f9378837ff644b92ae9472ca7c3e4e74b3860cb.tar.gz
feat: v1.0.2
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddaaca0b6896
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = mockplus-dt-font-agent-bin
+ pkgdesc = Mockplus DT - Font Agent
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://www.mockplus.cn/dt
+ arch = any
+ license = custom
+ provides = mockplus-dt-font-agent
+ source = mockplus-dt-font-agent.zip::https://dt.mockplus.cn/plugin-downloads/MockplusDTFontAgentInstall_linux_v1.0.2.zip
+ sha512sums = 7223c1594ac223c3232fa2548a56b54d471d580e0b9b723b8a62a0f63f98ca48651983aed123a261f8a2c92209086d78ed1edb4ee962c8032eb78f1e807c64da
+
+pkgname = mockplus-dt-font-agent-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4367ae4a50ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e78283ee9810
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: everyx <lunt.luo#gmail.com>
+
+_pkgname=mockplus-dt-font-agent
+pkgname=${_pkgname}-bin
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Mockplus DT - Font Agent"
+arch=("any")
+url="https://www.mockplus.cn/dt"
+license=("custom")
+provides=("${_pkgname}")
+source=("${_pkgname}.zip::https://dt.mockplus.cn/plugin-downloads/MockplusDTFontAgentInstall_linux_v${pkgver}.zip")
+sha512sums=("7223c1594ac223c3232fa2548a56b54d471d580e0b9b723b8a62a0f63f98ca48651983aed123a261f8a2c92209086d78ed1edb4ee962c8032eb78f1e807c64da")
+
+_user=mockplus
+
+build(){
+ sed -i -e "s|^ExecStart=.*$|ExecStart=/usr/bin/DTFontAgent \&|;
+ /^\[Service\]$/a User=$_user" \
+ DTFontAgent.service
+
+ echo "u $_user - \"Mockplus Service\" - -" > "$_user.conf"
+}
+
+package() {
+ install -Dm755 DTFontAgent -t "$pkgdir/usr/bin/"
+ install -Dm644 DTFontAgent.service -t "$pkgdir/usr/lib/systemd/system/"
+ install -Dm644 $_user.conf -t "$pkgdir/usr/lib/sysusers.d/"
+}