summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjujudusud2021-10-29 20:05:15 +0200
committerjujudusud2021-10-29 20:05:15 +0200
commit74d624a4e1d24a22a1df2d456d0045921e1043e0 (patch)
tree87271eb744a03ea1221ecfca932dc09d5ee8842e
parent65c98a5e28bcbd37d113cf556934e95c3df759f8 (diff)
downloadaur-74d624a4e1d24a22a1df2d456d0045921e1043e0.tar.gz
splitting mod-hodt and mod-ui packages
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 10 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f042af0d4ca..3aa7765d317a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mod-app-git
pkgdesc = Desktop application of the MOD interface and backend, natively integrated in the OS
- pkgver = 0.0.1.r155.gf2f1c2f
- pkgrel = 1
+ pkgver = 0.0.1.r160.gcaec366
+ pkgrel = 2
url = https://github.com/moddevices/mod-app
arch = x86_64
license = GPL3
@@ -12,14 +12,11 @@ pkgbase = mod-app-git
depends = python
depends = python-pyqt5
depends = hicolor-icon-theme
+ depends = mod-host-git
+ depends = mod-ui-git
provides = mod-app
conflicts = mod-app
source = mod-app-git::git+https://github.com/moddevices/mod-app.git
- source = mod-host::git+https://github.com/moddevices/mod-host.git
- source = mod-ui::git+https://github.com/moddevices/mod-ui.git
- md5sums = SKIP
- md5sums = SKIP
md5sums = SKIP
pkgname = mod-app-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 56b2486cf4d2..63183bb0cbd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,23 @@
# Maintainer: jujudusud <jujudusud@gmail.com>
pkgname=mod-app-git
-pkgver=0.0.1.r155.gf2f1c2f
-pkgrel=1
+pkgver=0.0.1.r160.gcaec366
+pkgrel=2
pkgdesc="Desktop application of the MOD interface and backend, natively integrated in the OS"
arch=('x86_64')
url="https://github.com/moddevices/mod-app"
license=('GPL3')
-depends=('jack2' 'lilv' 'lv2' 'python' 'python-pyqt5' 'hicolor-icon-theme')
+depends=('jack2' 'lilv' 'lv2' 'python' 'python-pyqt5' 'hicolor-icon-theme' 'mod-host-git' 'mod-ui-git')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("$pkgname::git+https://github.com/moddevices/${pkgname%-git}.git"
- 'mod-host::git+https://github.com/moddevices/mod-host.git'
- 'mod-ui::git+https://github.com/moddevices/mod-ui.git')
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP')
+source=("$pkgname::git+https://github.com/moddevices/${pkgname%-git}.git")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/$pkgname"
- git submodule init
- git config submodule.mod-host.url $srcdir/$pkgname/source/modules
- git config submodule.mod-ui.url $srcdir/$pkgname/source/modules
- git submodule update
-}
-
build() {
cd "$srcdir/$pkgname"
make
@@ -38,4 +26,4 @@ build() {
package() {
cd "$srcdir/$pkgname"
make PREFIX="/usr" DESTDIR="$pkgdir/" install
-} \ No newline at end of file
+}