summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurens Hazewinkel2018-03-10 22:27:17 +0100
committerLaurens Hazewinkel2018-03-10 22:27:17 +0100
commit4f8e42b622b6b7ba52148cbde4dfb88794ce3dda (patch)
treec2b094e48517bbb6c36decc1763ddbd0e530fc71
downloadaur-4f8e42b622b6b7ba52148cbde4dfb88794ce3dda.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c37354b4bd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mod-host-git
+ pkgdesc = LV2 host for Jack controllable via socket or command line
+ pkgver = 0.10.6.r270.g1726ad0
+ pkgrel = 1
+ url = https://github.com/moddevices/mod-host
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = lilv>=0.14.2
+ depends = fftw
+ provides = mod-host
+ conflicts = mod-host
+ source = git+https://github.com/moddevices/mod-host
+ md5sums = SKIP
+
+pkgname = mod-host-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f966f3fdc34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Laurens Hazewinkel <laurens dot hazewinkel at gmail dot com>
+pkgname=mod-host-git
+pkgver=0.10.6.r270.g1726ad0
+pkgrel=1
+pkgdesc="LV2 host for Jack controllable via socket or command line"
+arch=('x86_64')
+url="https://github.com/moddevices/mod-host"
+license=('GPL3')
+depends=('lilv>=0.14.2' 'fftw')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/moddevices/${pkgname%-git}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+ make PREFIX="/usr" DESTDIR="$pkgdir/" install
+}