summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien2021-02-27 19:31:56 +0100
committerJulien2021-02-27 19:31:56 +0100
commit8d25563744b6ac25b29095d9febe1b28d2f525d2 (patch)
treea6a7d6001e1ec9a34cde0f154a6002ee55e1b6cb
downloadaur-8d25563744b6ac25b29095d9febe1b28d2f525d2.tar.gz
creating git package
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD29
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..642cbc8ae50f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mod-ui-git
+ pkgdesc = UI for the MOD software, HTML5 webserver interface and commnicates with mod-host
+ pkgver = 0.99.8.r3148.g13435b8b
+ pkgrel = 1
+ url = https://github.com/moddevices/mod-ui
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pillow
+ depends = python-pyserial
+ depends = python-pystache
+ depends = python-tornado
+ depends = python-pycrypto
+ depends = python-aggdraw
+ depends = jack2
+ depends = lilv
+ depends = lv2
+ provides = mod-ui
+ conflicts = mod-ui
+ source = git+https://github.com/moddevices/mod-ui.git
+ md5sums = SKIP
+
+pkgname = mod-ui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f6d77107de6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: jujudusud <jujudusud@gmail.com>
+pkgname=mod-ui-git
+pkgver=0.99.8.r3148.g13435b8b
+pkgrel=1
+pkgdesc="UI for the MOD software, HTML5 webserver interface and commnicates with mod-host"
+arch=('x86_64')
+url="https://github.com/moddevices/mod-ui"
+license=('GPL3')
+depends=('python' 'python-pillow' 'python-pyserial' 'python-pystache' 'python-tornado' 'python-pycrypto' 'python-aggdraw' 'jack2' 'lilv' 'lv2')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/moddevices/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir" --skip-build --optimize=1
+} \ No newline at end of file