summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2020-03-31 22:36:46 -0700
committerSean Greenslade2020-03-31 22:36:46 -0700
commit9d089a002d5c9ee146982e7b22db52bb1ae1e26e (patch)
treed8d77c52416eb814f8413ab753dbed26bb8e957d
downloadaur-mod-utilities-lv2-git.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2713cf27743b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mod-utilities-lv2-git
+ pkgdesc = some moddevices LV2 plugins - latest git
+ pkgver = r141.4a92aa8
+ pkgrel = 1
+ url = https://github.com/moddevices/mod-utilities
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL2
+ makedepends = lv2
+ provides = mod-utilities-lv2
+ conflicts = mod-utilities-lv2
+ source = git+https://github.com/moddevices/mod-utilities
+ sha256sums = SKIP
+
+pkgname = mod-utilities-lv2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f305e73463f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sean Greenslade <aur AT seangreenslade DOT com>
+
+_pkgname=mod-utilities
+pkgname=$_pkgname-lv2-git
+pkgver=r141.4a92aa8
+pkgrel=1
+pkgdesc="some moddevices LV2 plugins - latest git"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/moddevices/mod-utilities"
+license=('GPL2')
+makedepends=('lv2')
+provides=('mod-utilities-lv2')
+conflicts=('mod-utilities-lv2')
+source=("git+https://github.com/moddevices/mod-utilities")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make install INSTALL_PATH="$pkgdir/usr/lib/lv2"
+}
+
+# vim:set ts=2 sw=2 et: