summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsparse2018-01-15 13:07:53 +0330
committersparse2018-01-15 13:07:53 +0330
commit5aaadd627c6af4ae1527799861b0ebcaff6808b9 (patch)
tree52099c994149375fb683892f61e042a289e206c1
downloadaur-5aaadd627c6af4ae1527799861b0ebcaff6808b9.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48c81679c2ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mod_auth_cas-git
+ pkgdesc = Apache CAS Authentication Module for the JASIG/Apereo CAS Server.
+ pkgver = r350.ac7147b
+ pkgrel = 1
+ url = https://github.com/louipc/tremc
+ arch = x86_64
+ license = Apache License, Version 2.0
+ makedepends = git
+ makedepends = openssl
+ depends = apache
+ source = git+https://github.com/apereo/mod_auth_cas.git
+ md5sums = SKIP
+
+pkgname = mod_auth_cas-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1b7340e012f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=mod_auth_cas-git
+_gitname=${pkgname%-git}
+pkgver=r350.ac7147b
+pkgrel=1
+pkgdesc="Apache CAS Authentication Module for the JASIG/Apereo CAS Server."
+arch=('x86_64')
+url="https://github.com/louipc/tremc"
+license=('Apache License, Version 2.0')
+depends=('apache')
+makedepends=('git' 'openssl')
+source=("git+https://github.com/apereo/mod_auth_cas.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_gitname"
+ sed -i s/SSL_library_init/OPENSSL_init_ssl/ configure.ac configure
+}
+
+build() {
+ cd "$_gitname"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim: ts=4 sts=4 sw=4 et