summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-09-04 11:32:14 +0300
committerCaleb Maclennan2021-09-04 11:32:14 +0300
commit722cc590afc73605f45ea950ee2d5a0b7375840d (patch)
tree818d640e14b36e0ac3a14ab1ea149cb016e16816
parent6eb2973ae81976573fffa1ff1b03b586926c8c88 (diff)
downloadaur-722cc590afc73605f45ea950ee2d5a0b7375840d.tar.gz
Switch from Git archive to upstream source dist
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 036d4168218f..8f0c4ba7694f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mod_auth_openidc
pkgdesc = OpenID Connect Relying Party implementation for Apache 2.x
pkgver = 2.4.9.4
- pkgrel = 2
+ pkgrel = 3
url = https://www.mod-auth-openidc.org/
arch = x86_64
license = Apache
@@ -10,7 +10,7 @@ pkgbase = mod_auth_openidc
depends = curl
depends = cjose
depends = pcre
- source = mod_auth_openidc-2.4.9.4.tar.gz::https://github.com/zmartzone/mod_auth_openidc/archive/v2.4.9.4.tar.gz
- sha512sums = cc4850cf88e5920fd944f5865f2bf0072f12d26a7f5aad38f378412dec01a9698c899616320a584a6e6d81f5dd50aaa1f5598cdc7cb50df6215dc516fa507d4e
+ source = https://github.com/zmartzone/mod_auth_openidc/releases/download/v2.4.9.4/mod_auth_openidc-2.4.9.4.tar.gz
+ sha512sums = 755f3343f87cd1b05d16e60afc86b68a79657adf793863215fba1bce6a12b8b7b18f60fba5041f82601d3ab2d526287ff3f88fef33673e84456d0423a90b1977
pkgname = mod_auth_openidc
diff --git a/PKGBUILD b/PKGBUILD
index 045f2458f13e..4168d8f7fc4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,25 @@
pkgname=mod_auth_openidc
pkgver=2.4.9.4
-pkgrel=2
+pkgrel=3
pkgdesc="OpenID Connect Relying Party implementation for Apache 2.x"
arch=('x86_64')
url="https://www.mod-auth-openidc.org/"
license=('Apache')
depends=('curl' 'cjose' 'pcre')
makedepends=('apache' 'jansson')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/zmartzone/mod_auth_openidc/archive/v$pkgver.tar.gz")
-sha512sums=('cc4850cf88e5920fd944f5865f2bf0072f12d26a7f5aad38f378412dec01a9698c899616320a584a6e6d81f5dd50aaa1f5598cdc7cb50df6215dc516fa507d4e')
+source=("https://github.com/zmartzone/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('755f3343f87cd1b05d16e60afc86b68a79657adf793863215fba1bce6a12b8b7b18f60fba5041f82601d3ab2d526287ff3f88fef33673e84456d0423a90b1977')
build() {
cd "$pkgname-$pkgver"
- ./autogen.sh
APXS2_OPTS="-S LIBEXECDIR=$pkgdir/usr/lib/httpd/modules/" ./configure --prefix=/usr
make
}
package() {
cd "$pkgname-$pkgver"
+ # Upstream Issue: https://github.com/zmartzone/mod_auth_openidc/issues/674
install -dm755 "$pkgdir/usr/lib/httpd/modules"
make install
}