summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralzeih2020-08-20 22:51:47 +1200
committeralzeih2020-08-20 22:51:47 +1200
commit997257596b57d901c1633d8cc50ab0ab3adbf663 (patch)
treeba69514d0c49b64338a27cb4f882837246c571fc
downloadaur-997257596b57d901c1633d8cc50ab0ab3adbf663.tar.gz
Version 2.4.3-1
Signed-off-by: alzeih <alzeih@users.noreply.github.com>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..215ea3bf163f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mod_auth_openidc
+ pkgdesc = An authentication/authorization module for the Apache 2.x HTTP server that functions as an OpenID Connect Relying Party, authenticating users against an OpenID Connect Provider.
+ pkgver = 2.4.3
+ pkgrel = 1
+ url = https://www.mod-auth-openidc.org/
+ arch = x86_64
+ license = Apache
+ makedepends = apache
+ makedepends = jansson
+ makedepends = cjose
+ depends = curl
+ depends = cjose
+ depends = pcre
+ source = https://github.com/zmartzone/mod_auth_openidc/releases/download/v2.4.3/mod_auth_openidc-2.4.3.tar.gz
+ sha512sums = c4fa4f99f2005cab230f4b8a3dd70cc99c281fc4ff679472f0c1a5920372b53ce2b5e34a8f87e14fc92055d3b9c75dd58f77f539f69571a1af0db10bdc6ea1ab
+
+pkgname = mod_auth_openidc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0953494b0a5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: alzeih <alzeih@users.noreply.github.com>
+pkgname=mod_auth_openidc
+pkgver=2.4.3
+pkgrel=1
+pkgdesc="An authentication/authorization module for the Apache 2.x HTTP server that functions as an OpenID Connect Relying Party, authenticating users against an OpenID Connect Provider."
+arch=('x86_64')
+url="https://www.mod-auth-openidc.org/"
+license=('Apache')
+depends=('curl' 'cjose' 'pcre')
+makedepends=('apache' 'jansson' 'cjose')
+source=("https://github.com/zmartzone/mod_auth_openidc/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+noextract=()
+sha512sums=('c4fa4f99f2005cab230f4b8a3dd70cc99c281fc4ff679472f0c1a5920372b53ce2b5e34a8f87e14fc92055d3b9c75dd58f77f539f69571a1af0db10bdc6ea1ab')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ APXS2_OPTS="-S LIBEXECDIR=$pkgdir/usr/lib/httpd/modules/" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -dm755 "$pkgdir/usr/lib/httpd/modules"
+ make install
+}
+