summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-11-24 03:26:50 +0300
committerCaleb Maclennan2021-11-24 03:26:50 +0300
commitc79e927732abebf97d642c65a440b7041e249c88 (patch)
treeaafa6c1abe460480c04ffad726d8f55dd774d4df
parent515677a5260927be0cf1aab00477efdf562e2c75 (diff)
downloadaur-c79e927732abebf97d642c65a440b7041e249c88.tar.gz
upgpkg: mod_auth_openidc 2.4.10-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f0c4ba7694f..f4ca9d4957f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mod_auth_openidc
pkgdesc = OpenID Connect Relying Party implementation for Apache 2.x
- pkgver = 2.4.9.4
- pkgrel = 3
+ pkgver = 2.4.10
+ pkgrel = 1
url = https://www.mod-auth-openidc.org/
arch = x86_64
license = Apache
@@ -10,7 +10,7 @@ pkgbase = mod_auth_openidc
depends = curl
depends = cjose
depends = pcre
- source = https://github.com/zmartzone/mod_auth_openidc/releases/download/v2.4.9.4/mod_auth_openidc-2.4.9.4.tar.gz
- sha512sums = 755f3343f87cd1b05d16e60afc86b68a79657adf793863215fba1bce6a12b8b7b18f60fba5041f82601d3ab2d526287ff3f88fef33673e84456d0423a90b1977
+ source = https://github.com/zmartzone/mod_auth_openidc/releases/download/v2.4.10/mod_auth_openidc-2.4.10.tar.gz
+ sha512sums = 5e2b587d7cbae290242aec8d94047c64061c2554d9458be6085bdb643d447feb48d56748198ade1de390cd4babdaf81d9e1f5e06d5a05ce8d164520c4f5a1ca7
pkgname = mod_auth_openidc
diff --git a/PKGBUILD b/PKGBUILD
index 3fab8eb6aa1b..61867d05e09c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=mod_auth_openidc
-pkgver=2.4.9.4
-pkgrel=3
+pkgver=2.4.10
+pkgrel=1
pkgdesc="OpenID Connect Relying Party implementation for Apache 2.x"
arch=('x86_64')
url="https://www.mod-auth-openidc.org/"
@@ -11,18 +11,22 @@ license=('Apache')
depends=('curl' 'cjose' 'pcre')
makedepends=('apache' 'jansson')
source=("https://github.com/zmartzone/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha512sums=('755f3343f87cd1b05d16e60afc86b68a79657adf793863215fba1bce6a12b8b7b18f60fba5041f82601d3ab2d526287ff3f88fef33673e84456d0423a90b1977')
+sha512sums=('5e2b587d7cbae290242aec8d94047c64061c2554d9458be6085bdb643d447feb48d56748198ade1de390cd4babdaf81d9e1f5e06d5a05ce8d164520c4f5a1ca7')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ # switch installation methods, the one we need is commented
+ sed -i -e '72d;73{s/^.//;s/@/$(DESTDIR)@/}' Makefile.am
+}
build() {
cd "$pkgname-$pkgver"
- APXS2_OPTS="-S LIBEXECDIR=$pkgdir/usr/lib/httpd/modules/" ./configure --prefix=/usr
+ ./configure --prefix=/usr
make
}
package() {
cd "$pkgname-$pkgver"
- # Upstream Issue: https://github.com/zmartzone/mod_auth_openidc/issues/674
- install -dm755 "$pkgdir/usr/lib/httpd/modules"
- make install
+ make install DESTDIR="$pkgdir"
}