summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-01-26 20:30:28 +0300
committerCaleb Maclennan2022-01-26 20:30:47 +0300
commitfa1d3c5234a38301bb7a8534880c8da191c61c6c (patch)
tree4c6e110edda9b7beb1a14e8f6fabe42d9bfb31f6
parent8d6f8a4acd8454a899c5f350ceaee22cb260fc0d (diff)
downloadaur-fa1d3c5234a38301bb7a8534880c8da191c61c6c.tar.gz
upgpkg: mod_auth_openidc 2.4.11-2; fix dependencies, overhaul style
Style changes are because I'm slating this for migration to [community].
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
2 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f671b9dcc441..0913710264ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = mod_auth_openidc
pkgdesc = OpenID Connect Relying Party implementation for Apache 2.x
pkgver = 2.4.11
- pkgrel = 1
- url = https://www.mod-auth-openidc.org/
+ pkgrel = 2
+ url = https://www.mod-auth-openidc.org
arch = x86_64
license = Apache
makedepends = apache
makedepends = jansson
- depends = curl
depends = cjose
- depends = pcre
+ depends = openssl
+ depends = pcre2
source = https://github.com/zmartzone/mod_auth_openidc/releases/download/v2.4.11/mod_auth_openidc-2.4.11.tar.gz
- sha512sums = 9eed1257c308c0a6dd2ac3f5c7c997604f1f6b0ae855a7b094ac800f2e1ea90ad71fbaeecd99ec74d0e9cc2d67d1604710b3f06c13b63aa78b23dd1cb859a736
+ sha256sums = 5140333b384c879bc7352badd9622e21fb46fdbf8ca6716423cb2d1e1ba0e2ac
pkgname = mod_auth_openidc
diff --git a/PKGBUILD b/PKGBUILD
index 324c0b1d88c3..b9dcb1ee9089 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,25 @@
pkgname=mod_auth_openidc
pkgver=2.4.11
-pkgrel=1
-pkgdesc="OpenID Connect Relying Party implementation for Apache 2.x"
-arch=('x86_64')
-url="https://www.mod-auth-openidc.org/"
-license=('Apache')
-depends=('curl' 'cjose' 'pcre')
-makedepends=('apache' 'jansson')
-source=("https://github.com/zmartzone/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha512sums=('9eed1257c308c0a6dd2ac3f5c7c997604f1f6b0ae855a7b094ac800f2e1ea90ad71fbaeecd99ec74d0e9cc2d67d1604710b3f06c13b63aa78b23dd1cb859a736')
+pkgrel=2
+pkgdesc='OpenID Connect Relying Party implementation for Apache 2.x'
+arch=(x86_64)
+url=https://www.mod-auth-openidc.org
+license=(Apache)
+depends=(cjose openssl pcre2)
+_archive="$pkgname-$pkgver"
+makedepends=(apache jansson)
+source=("https://github.com/zmartzone/$pkgname/releases/download/v$pkgver/$_archive.tar.gz")
+sha256sums=('5140333b384c879bc7352badd9622e21fb46fdbf8ca6716423cb2d1e1ba0e2ac')
build() {
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
- make
+ cd "$_archive"
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ cd "$_archive"
+ make DESTDIR="$pkgdir" install
}