summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gwin2015-10-16 15:17:18 +0200
committerMichael Gwin2015-10-16 15:17:18 +0200
commit3bfbfbaa37f7e871bbf29253dcaad1c907516be6 (patch)
tree3e7db89f728250040cf042a3a6c19537af504e78
downloadaur-3bfbfbaa37f7e871bbf29253dcaad1c907516be6.tar.gz
Inital import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--mod_authnz_external.install12
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..280408ee45d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mod_authnz_external
+ pkgdesc = Apache External Authentication Modules
+ pkgver = 3.3.2
+ pkgrel = 1
+ url = http://code.google.com/p/mod-auth-external/
+ install = mod_authnz_external.install
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = apache>=2.4.0
+ source = http://mod-auth-external.googlecode.com/files/mod_authnz_external-3.3.2.tar.gz
+ sha1sums = c3b9b25b0c2043d1fd7ab4572a01a9c58f226fc1
+
+pkgname = mod_authnz_external
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c37d1bc71a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Michael Gwin <oksijun+arch at gmail dot com>
+# Contributor: Graziano Giuliani <g.giuliani@seco.it>
+# Contributor: Pierre Bourdon <delroth@gmail.com>
+# Contributor: Arthur Darcet <arthur.darcet@m4x.org>
+
+pkgname=mod_authnz_external
+pkgver=3.3.2
+pkgrel=1
+pkgdesc='Apache External Authentication Modules'
+arch=('i686' 'x86_64')
+url='http://code.google.com/p/mod-auth-external/'
+license=('Apache')
+makedepends=('apache>=2.4.0')
+install=mod_authnz_external.install
+source=(http://mod-auth-external.googlecode.com/files/$pkgname-$pkgver.tar.gz)
+sha1sums=('c3b9b25b0c2043d1fd7ab4572a01a9c58f226fc1')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make build || return 1
+ install -D -m755 .libs/mod_authnz_external.so $pkgdir/usr/lib/httpd/modules/mod_authnz_external.so
+}
diff --git a/mod_authnz_external.install b/mod_authnz_external.install
new file mode 100644
index 000000000000..3149ee563cb3
--- /dev/null
+++ b/mod_authnz_external.install
@@ -0,0 +1,12 @@
+post_install() {
+ cat << EOM
+
+--> Add the following line to the modules section of your apache config
+ LoadModule authnz_external_module modules/mod_authnz_external.so
+EOM
+ /bin/true
+}
+
+post_upgrade() {
+ post_install $i
+}