summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Mogas da Silva2017-01-17 20:36:04 +0000
committerCarlos Mogas da Silva2017-01-17 20:36:04 +0000
commit3b3f15b256dbdd3b910146edcaf81dd3f39b2b27 (patch)
tree6b9dcf945adc70b72b3b567125594837488f60ce
downloadaur-3b3f15b256dbdd3b910146edcaf81dd3f39b2b27.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c80b5573e7b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mod_authnz_pam
+ pkgdesc = Apache module to run PAM authorization on result of other module's authentication; also full Basic Auth PAM provider.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://www.adelton.com/apache/mod_authnz_pam/
+ arch = i686
+ arch = x86_64
+ license = apache-2.0
+ makedepends = pkgconfig
+ depends = apache
+ depends = pam
+ source = https://github.com/adelton/mod_authnz_pam/archive/mod_authnz_pam-1.1.0.tar.gz
+ sha1sums = 18495384f2bb5c702f6a02b4a84043ded8f964a5
+
+pkgname = mod_authnz_pam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8880ac03cd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Carlos Silva <r3pek@r3pek.org>
+
+pkgname=mod_authnz_pam
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Apache module to run PAM authorization on result of other module's authentication; also full Basic Auth PAM provider."
+arch=('i686' 'x86_64')
+license=('apache-2.0')
+url="https://www.adelton.com/apache/mod_authnz_pam/"
+depends=('apache'
+ 'pam')
+makedepends=('pkgconfig')
+source=(https://github.com/adelton/mod_authnz_pam/archive/${pkgname}-${pkgver}.tar.gz)
+sha1sums=('18495384f2bb5c702f6a02b4a84043ded8f964a5')
+
+build() {
+ cd "${pkgname}-${pkgname}-${pkgver}"
+ apxs -c mod_authnz_pam.c -lpam -Wall -pedantic
+}
+
+package() {
+ cd "${pkgname}-${pkgname}-${pkgver}"
+
+ APACHE_MOD_DIR=$(apxs -q libexecdir)
+ install -D -m755 .libs/mod_authnz_pam.so ${pkgdir}/${APACHE_MOD_DIR}/mod_authnz_pam.so
+
+ APACHE_CONF_DIR=$(apxs -q sysconfdir)
+ install -D -m644 authnz_pam.conf ${pkgdir}/${APACHE_CONF_DIR}/extra/authnz_pam.conf
+ install -D -m644 authnz_pam.module ${pkgdir}/${APACHE_CONF_DIR}/authnz_pam.conf
+
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}