summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2018-05-28 01:36:29 +0200
committerMarcin Wieczorek2018-05-28 01:36:29 +0200
commit1491fc76daf6cc5a6f3e2b9ce24ef1fd63e6a976 (patch)
tree4de90efa2e6fdbce5904d3ba60b0c63b8b7c4b80
parentdf25044bc87fb509ae0b01fda310b3ff8e901b3f (diff)
downloadaur-1491fc76daf6cc5a6f3e2b9ce24ef1fd63e6a976.tar.gz
Version 0.8.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD16
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50992c5bfcb1..b1a04bd7b46f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = mod_gnutls
pkgdesc = Apache module for the GnuTLS library
- pkgver = 0.7.5
+ pkgver = 0.8.3
pkgrel = 1
- url = http://modgnutls.sourceforge.net/
+ url = https://mod.gnutls.org/
install = mod_gnutls.install
arch = i686
arch = x86_64
license = Apache
- depends = apache>=2.0.42
- depends = gnutls>=2.12.6
- optdepends = aprmemcache>=0.7.0
- source = http://mod.gnutls.org/downloads/mod_gnutls-0.7.5.tar.bz2
- source = http://mod.gnutls.org/downloads/mod_gnutls-0.7.5.tar.bz2.asc
+ depends = apache
+ depends = gnutls
+ optdepends = aprmemcache
+ source = http://mod.gnutls.org/downloads/mod_gnutls-0.8.3.tar.bz2
+ source = http://mod.gnutls.org/downloads/mod_gnutls-0.8.3.tar.bz2.asc
validpgpkeys = B471C74C72A7F6EC9FFA46E361459C5287768C53
- md5sums = 6129006fa689d241fceeae6fd4dcf9d6
- md5sums = SKIP
+ sha256sums = 3517dddef04e0cb64c4805799d1b749bb6273f99c3ac33634677210fbe60292b
+ sha256sums = SKIP
pkgname = mod_gnutls
diff --git a/PKGBUILD b/PKGBUILD
index 7b431164b8d2..496c8c24be4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,26 @@
# Contributor: David Zaragoza <david@zaragoza.com.ve>
pkgname=mod_gnutls
-pkgver=0.7.5
+pkgver=0.8.3
pkgrel=1
pkgdesc="Apache module for the GnuTLS library"
arch=('i686' 'x86_64')
-url="http://modgnutls.sourceforge.net/"
+url="https://mod.gnutls.org/"
license=('Apache')
-depends=('apache>=2.0.42' 'gnutls>=2.12.6')
-optdepends=('aprmemcache>=0.7.0')
+depends=('apache' 'gnutls')
+optdepends=('aprmemcache')
install=${pkgname}.install
source=("http://mod.gnutls.org/downloads/${pkgname}-${pkgver}.tar.bz2"{,.asc})
-md5sums=('6129006fa689d241fceeae6fd4dcf9d6'
- 'SKIP')
+sha256sums=('3517dddef04e0cb64c4805799d1b749bb6273f99c3ac33634677210fbe60292b'
+ 'SKIP')
#Thomas Klute <thomas2.klute@uni-dortmund.de>
validpgpkeys=('B471C74C72A7F6EC9FFA46E361459C5287768C53')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure
+ autoreconf -fiv
+ ./configure --with-apxs=/usr/bin/apxs
make
}
@@ -30,4 +31,5 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
sed -ir 's/@${APXS_BIN} -i -n gnutls mod_gnutls.so/mkdir -p $(DESTDIR)$(AP_LIBEXECDIR)\n\t@${APXS_BIN} -i -S LIBEXECDIR=$(DESTDIR)$(AP_LIBEXECDIR) -n gnutls mod_gnutls.so/' src/Makefile
make DESTDIR="${pkgdir}/" install
+ libtool --finish "${pkgdir}/usr/lib/httpd/modules"
}