summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2016-05-30 15:47:10 +0200
committerMarcin Wieczorek2016-05-30 15:47:10 +0200
commitdf25044bc87fb509ae0b01fda310b3ff8e901b3f (patch)
tree73370842f92f19a08a060ef3d23f5e4907e25d1a
downloadaur-df25044bc87fb509ae0b01fda310b3ff8e901b3f.tar.gz
Version 0.7.5
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
-rw-r--r--mod_gnutls.install19
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50992c5bfcb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mod_gnutls
+ pkgdesc = Apache module for the GnuTLS library
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = http://modgnutls.sourceforge.net/
+ install = mod_gnutls.install
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = apache>=2.0.42
+ depends = gnutls>=2.12.6
+ optdepends = aprmemcache>=0.7.0
+ source = http://mod.gnutls.org/downloads/mod_gnutls-0.7.5.tar.bz2
+ source = http://mod.gnutls.org/downloads/mod_gnutls-0.7.5.tar.bz2.asc
+ validpgpkeys = B471C74C72A7F6EC9FFA46E361459C5287768C53
+ md5sums = 6129006fa689d241fceeae6fd4dcf9d6
+ md5sums = SKIP
+
+pkgname = mod_gnutls
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b431164b8d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Marcin Wieczorek <marcin@marcin.co>
+# Contributor: Michael Rasmussen <michael@michaelsnet.us>
+# Contributor: Matt Kemp <matt@mattikus.com>
+# Contributor: David Zaragoza <david@zaragoza.com.ve>
+
+pkgname=mod_gnutls
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="Apache module for the GnuTLS library"
+arch=('i686' 'x86_64')
+url="http://modgnutls.sourceforge.net/"
+license=('Apache')
+depends=('apache>=2.0.42' 'gnutls>=2.12.6')
+optdepends=('aprmemcache>=0.7.0')
+install=${pkgname}.install
+source=("http://mod.gnutls.org/downloads/${pkgname}-${pkgver}.tar.bz2"{,.asc})
+md5sums=('6129006fa689d241fceeae6fd4dcf9d6'
+ 'SKIP')
+
+#Thomas Klute <thomas2.klute@uni-dortmund.de>
+validpgpkeys=('B471C74C72A7F6EC9FFA46E361459C5287768C53')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -ir 's/@${APXS_BIN} -i -n gnutls mod_gnutls.so/mkdir -p $(DESTDIR)$(AP_LIBEXECDIR)\n\t@${APXS_BIN} -i -S LIBEXECDIR=$(DESTDIR)$(AP_LIBEXECDIR) -n gnutls mod_gnutls.so/' src/Makefile
+ make DESTDIR="${pkgdir}/" install
+}
diff --git a/mod_gnutls.install b/mod_gnutls.install
new file mode 100644
index 000000000000..e8b0c86a8f9b
--- /dev/null
+++ b/mod_gnutls.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo " >>> To enable mod_gnutls:"
+ echo " >>> add the following line in"
+ echo " >>> /etc/httpd/conf/httpd.conf"
+ echo " >>>"
+ echo " >>> LoadModule gnutls_module modules/mod_gnutls.so"
+ echo " >>>"
+ echo " >>> Ensure all directives to 'load mod_ssl' are removed"
+ echo " >>> and restart/reload Apache."
+ echo " >>>"
+ echo " >>> Additional configuration will be required. See:"
+ echo " >>> https://wiki.archlinux.org/index.php/Mod_gnutls and"
+}
+
+post_upgrade() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: