summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Trepczik2016-05-28 14:12:04 +0200
committerAndreas Trepczik2016-05-28 14:12:04 +0200
commit1ebfec579193b44a45769a843696548aee5ba61e (patch)
treec7541fd26bf176f152cfb8be2dc05c22b21ce88d
downloadaur-mod_markdown.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe0b6ad73168
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mod_markdown
+ pkgdesc = Markdown filter module for Apache HTTPD Server
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/hamano/apache-mod-markdown
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ depends = apache
+ depends = discount
+ source = https://github.com/hamano/apache-mod-markdown/archive/1.0.3.tar.gz
+ sha256sums = 62111266af0a1ee5ea7e595caf94ea33d1459d633ae0e063edc173fae243810f
+
+pkgname = mod_markdown
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de01222dbb34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: bzt <unmacaque (at) gmail (dot) com>
+
+pkgname=mod_markdown
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Markdown filter module for Apache HTTPD Server"
+arch=('i686' 'x86_64')
+url="https://github.com/hamano/apache-mod-markdown"
+license=('APACHE')
+depends=('apache' 'discount')
+_srcname=apache-mod-markdown
+source=("https://github.com/hamano/$_srcname/archive/$pkgver.tar.gz")
+sha256sums=("62111266af0a1ee5ea7e595caf94ea33d1459d633ae0e063edc173fae243810f")
+
+build() {
+ cd "$_srcname-$pkgver"
+ autoreconf -f -i
+ ./configure --with-apxs=/usr/bin/apxs --with-discount=/usr
+ make
+}
+
+package() {
+ cd "$_srcname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}