summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-11-10 15:50:30 +0000
committerAntonio Rojas2017-11-10 15:50:30 +0000
commit1147954b82805c0ad64f0baff0e395ebf6664216 (patch)
treee69ec87310ff2ea1915cc11754f2b3b2d0c44428
downloadaur-1147954b82805c0ad64f0baff0e395ebf6664216.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aaadbdeac67d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mod_mono
+ pkgdesc = The mono module to make ASP.NET running on top of apache
+ pkgver = 3.12
+ pkgrel = 2
+ url = http://www.go-mono.com
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ depends = apache
+ depends = xsp
+ source = http://download.mono-project.com/sources/mod_mono/mod_mono-3.12.tar.gz
+ md5sums = bb99d807ce32040370360fae4996f967
+
+pkgname = mod_mono
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f794d4342fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 242171 2015-07-13 18:24:21Z daniel $
+# Maintainer: Daniel Isenmann <daniel@archlinux.org>
+# Contributor: Tobias Kieslich <tobias@justdreams.de>
+
+pkgname=mod_mono
+pkgver=3.12
+pkgrel=2
+pkgdesc="The mono module to make ASP.NET running on top of apache"
+arch=('i686' 'x86_64')
+url="http://www.go-mono.com"
+license=('APACHE')
+source=(http://download.mono-project.com/sources/mod_mono/${pkgname}-${pkgver}.tar.gz)
+depends=('apache' 'xsp')
+md5sums=('bb99d807ce32040370360fae4996f967')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ CFLAGS="${CFLAGS} `apr-1-config --cppflags --includes --cflags`" ./configure \
+ --prefix=/usr --sysconfdir=/etc --with-apxs=/usr/bin/apxs \
+ --with-mono-prefix=/usr --with-apr-config=/usr/bin/apr-1-config
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ mkdir -p ${pkgdir}/etc/httpd/conf/extra
+ mv ${pkgdir}/etc/httpd/conf/mod_mono.conf ${pkgdir}/etc/httpd/conf/extra/mod_mono.conf
+}
+