summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonard de Ruijter2015-06-02 19:09:01 +0200
committerLeonard de Ruijter2015-06-02 19:09:01 +0200
commita635473db59fa053e3cc7a3ff3c5a627e83fb853 (patch)
tree9a55a4a18648082f9b826329847e5efd1d41a06f
downloadaur-a635473db59fa053e3cc7a3ff3c5a627e83fb853.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD23
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e60d9738160d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mod_musicindex
+ pkgdesc = An Apache module which allows nice displaying of directories containing MP3, FLAC, Ogg Vorbis or MP4/AAC files.
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = http://hacks.slashdirt.org/musicindex/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = apache
+ depends = flac
+ depends = libarchive
+ depends = libid3tag
+ depends = libmad
+ depends = libmariadbclient
+ depends = libmp4v2
+ depends = libvorbis
+ options = !strip
+ source = http://hacks.slashdirt.org/musicindex/mod_musicindex-1.4.1.tar.gz
+ md5sums = cf758050b689fe16c5ff8f8c5da5cfa4
+
+pkgname = mod_musicindex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f16ee55b3103
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Leonard de Ruijter <leonard@aur.archlinux.org>
+pkgname=mod_musicindex
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="An Apache module which allows nice displaying of directories containing MP3, FLAC, Ogg Vorbis or MP4/AAC files."
+url="http://hacks.slashdirt.org/musicindex/"
+arch=('i686' 'x86_64')
+options=('!strip')
+license=('LGPL2.1')
+depends=('apache' 'flac' 'libarchive' 'libid3tag' 'libmad' 'libmariadbclient' 'libmp4v2' 'libvorbis')
+source=(http://hacks.slashdirt.org/musicindex/$pkgname-$pkgver.tar.gz)
+md5sums=('cf758050b689fe16c5ff8f8c5da5cfa4')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --datarootdir=/usr/share/
+ make all
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+}