summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2020-10-30 22:57:45 +0100
committerMichal Wojdyla2020-10-30 22:57:45 +0100
commitc61d9e88c0b58c6d09aa5a3e849a1f99be0e0f13 (patch)
treeb859394546ae19e5d2686e5ff7b10776e0bf0b2b
parent11898bcd0156fa12e7879142433932e843fa27a1 (diff)
downloadaur-c61d9e88c0b58c6d09aa5a3e849a1f99be0e0f13.tar.gz
Fix compilation with python 3.7
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd5ad124949e..8cca5d4c9e94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mod_python
pkgdesc = An Apache module that embeds the Python interpreter within the server
pkgver = 3.5.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.modpython.org/
install = mod_python.install
arch = i686
@@ -12,8 +12,8 @@ pkgbase = mod_python
conflicts = mod_python2-legacy
conflicts = mod_python2
options = !strip
- source = http://dist.modpython.org/dist/mod_python-3.5.0.tgz
- md5sums = 2e61621e8d030f535f112d8e739161e2
+ source = mod_python-8fb45feab94152a6aae3492aed4b81c363a912bd.zip::https://github.com/grisha/mod_python/archive/8fb45feab94152a6aae3492aed4b81c363a912bd.zip
+ md5sums = e918cb1141d17aa754d1a51cbd458112
pkgname = mod_python
diff --git a/PKGBUILD b/PKGBUILD
index 3b27d7b4b572..9afbe6c40a35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Allen Zhong <moeallenz@gmail.com>
+# Contributor: Michal Wojdyla < micwoj9292 at gmail dot com >
+# Contributor: Allen Zhong <moeallenz@gmail.com>
# Contributor: Jonathan Liu <net147@gmail.com>
-
+_hash=8fb45feab94152a6aae3492aed4b81c363a912bd
pkgname=mod_python
pkgver=3.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="An Apache module that embeds the Python interpreter within the server"
arch=('i686' 'x86_64')
url="http://www.modpython.org/"
@@ -11,12 +12,12 @@ license=('APACHE')
depends=('apache' 'python')
conflicts=('mod_python2-legacy' 'mod_python2')
install="$pkgname.install"
-source=("http://dist.modpython.org/dist/$pkgname-$pkgver.tgz")
+source=(mod_python-$_hash.zip::https://github.com/grisha/mod_python/archive/$_hash.zip)
options=('!strip')
-md5sums=('2e61621e8d030f535f112d8e739161e2')
+md5sums=('e918cb1141d17aa754d1a51cbd458112')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$_hash"
sed -i -e "s#git describe --always#echo $pkgrel#" dist/version.sh
./configure --prefix=/usr --with-python=/usr/bin/python
sed -i -e "s#-Wl[^ ]*#$LDFLAGS#g" src/Makefile
@@ -24,7 +25,8 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$_hash"
install -d "$pkgdir"/usr/bin
make DESTDIR="$pkgdir" install
}
+