summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2014-05-05 17:38:02 +0800
committerAllen Zhong2014-05-05 17:38:02 +0800
commitd8b7294123a500b29417b99dd6f78673fdfbce32 (patch)
tree495e481eb720f58b87fcdadeb3a8279888d5d084
downloadaur-d8b7294123a500b29417b99dd6f78673fdfbce32.tar.gz
newpkg: mod_python 3.5.0-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
-rw-r--r--mod_python.install8
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd5ad124949e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mod_python
+ pkgdesc = An Apache module that embeds the Python interpreter within the server
+ pkgver = 3.5.0
+ pkgrel = 2
+ url = http://www.modpython.org/
+ install = mod_python.install
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ depends = apache
+ depends = python
+ conflicts = mod_python2-legacy
+ conflicts = mod_python2
+ options = !strip
+ source = http://dist.modpython.org/dist/mod_python-3.5.0.tgz
+ md5sums = 2e61621e8d030f535f112d8e739161e2
+
+pkgname = mod_python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88d41ff2bd61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Allen Zhong <moeallenz@gmail.com>
+# Contributor: Jonathan Liu <net147@gmail.com>
+
+pkgname=mod_python
+pkgver=3.5.0
+pkgrel=1
+pkgdesc="An Apache module that embeds the Python interpreter within the server"
+arch=('i686' 'x86_64')
+url="http://www.modpython.org/"
+license=('APACHE')
+depends=('apache' 'python')
+conflicts=('mod_python2-legacy' 'mod_python2')
+install="$pkgname.install"
+source=("http://dist.modpython.org/dist/$pkgname-$pkgver.tgz")
+options=('!strip')
+md5sums=('2e61621e8d030f535f112d8e739161e2')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --with-python=/usr/bin/python
+ sed -i -e "s#-Wl[^ ]*#$LDFLAGS#g" src/Makefile
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -d "$pkgdir"/usr/bin
+ make DESTDIR="$pkgdir" install
+}
diff --git a/mod_python.install b/mod_python.install
new file mode 100644
index 000000000000..10a1211d3233
--- /dev/null
+++ b/mod_python.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo
+ echo "Now don't forget to edit your main config and add"
+ echo " LoadModule python_module /usr/lib/httpd/modules/mod_python.so"
+ echo "and if your configuration uses ClearModuleList, then also"
+ echo " AddModule mod_python.c"
+ echo
+}