summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gwin2015-10-17 10:06:01 +0200
committerMichael Gwin2015-10-17 10:06:01 +0200
commit4bfbc1adc2054ef75a358b5cd3faa37050ac61c9 (patch)
tree5e3c5d6864f8bd43a460b29135c383dcb8ac4cad
downloadaur-4bfbc1adc2054ef75a358b5cd3faa37050ac61c9.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--apache24.patch49
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e66e4a7b555e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mod_scgi
+ pkgdesc = Apache module that implements SCGI protocol
+ pkgver = 1.14
+ pkgrel = 5
+ url = http://python.ca/scgi/
+ arch = i686
+ arch = x86_64
+ arch = armv5h
+ arch = armv6h
+ arch = armv7h
+ license = custom
+ makedepends = apache
+ source = http://python.ca/scgi/releases/scgi-1.14.tar.gz
+ source = apache24.patch
+ md5sums = 73d942a9ecdf4f20c8234e72ea82c7ee
+ md5sums = bf3d7766a3ac7e2bd44ebfa1e858f4d5
+
+pkgname = mod_scgi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be05e66e5f4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Michael Gwin <oksijun+arch at gmail dot com>
+# Contributor: Roman Cheplyaka <roma@ro-che.info>
+
+pkgname=mod_scgi
+pkgver=1.14
+pkgrel=5
+pkgdesc="Apache module that implements SCGI protocol"
+url="http://python.ca/scgi/"
+makedepends=('apache')
+license=('custom')
+arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h')
+source=(http://python.ca/scgi/releases/scgi-$pkgver.tar.gz apache24.patch)
+md5sums=('73d942a9ecdf4f20c8234e72ea82c7ee' 'bf3d7766a3ac7e2bd44ebfa1e858f4d5')
+
+prepare() {
+ cd $srcdir/scgi-$pkgver/apache2
+ patch -p2 -i $srcdir/apache24.patch
+ sed -i 's/apxs2/apxs/g' Makefile || return 1
+}
+
+build() {
+ cd $srcdir/scgi-$pkgver/apache2
+ make || return 1
+}
+
+package() {
+ install -m 644 -D \
+ $srcdir/scgi-$pkgver/apache2/.libs/mod_scgi.so \
+ $pkgdir/usr/lib/httpd/modules/mod_scgi.so || return 1
+ install -m 644 -D \
+ $srcdir/scgi-$pkgver/LICENSE.txt \
+ $pkgdir/usr/share/licenses/${pkgname}/LICENSE.txt || return 1
+ install -m 644 -D \
+ $srcdir/scgi-$pkgver/doc/LICENSE_110.txt \
+ $pkgdir/usr/share/licenses/${pkgname}/LICENSE_110.txt || return 1
+}
diff --git a/apache24.patch b/apache24.patch
new file mode 100644
index 000000000000..8c1240b18c31
--- /dev/null
+++ b/apache24.patch
@@ -0,0 +1,49 @@
+--- a/apache2/mod_scgi.c
++++ b/apache2/mod_scgi.c
+@@ -135,16 +135,16 @@
+ return DECLINED;
+ }
+
+-static void log_err(const char *file, int line, request_rec *r,
++static void log_err(const char *file, int line, int index, request_rec *r,
+ apr_status_t status, const char *msg)
+ {
+- ap_log_rerror(file, line, APLOG_ERR, status, r, "scgi: %s", msg);
++ ap_log_rerror(file, line, index, APLOG_ERR, status, r, "scgi: %s", msg);
+ }
+
+-static void log_debug(const char *file, int line, request_rec *r, const
++static void log_debug(const char *file, int line, int index, request_rec *r, const
+ char *msg)
+ {
+- ap_log_rerror(file, line, APLOG_DEBUG, APR_SUCCESS, r, msg);
++ ap_log_rerror(file, line, index, APLOG_DEBUG, APR_SUCCESS, r, "%s", msg);
+ }
+
+ static char *http2env(apr_pool_t *p, const char *name)
+@@ -312,7 +312,7 @@
+ int i;
+ apr_status_t rv = 0;
+ apr_port_t port = 0;
+- GET_PORT(port, r->connection->remote_addr);
++ GET_PORT(port, r->useragent_addr);
+
+ log_debug(APLOG_MARK,r, "sending headers");
+ t = apr_table_make(r->pool, 40);
+@@ -324,14 +324,14 @@
+ buf = "0";
+ add_header(t, "CONTENT_LENGTH", buf);
+ add_header(t, "SCGI", SCGI_PROTOCOL_VERSION);
+- add_header(t, "SERVER_SOFTWARE", ap_get_server_version());
++ add_header(t, "SERVER_SOFTWARE", ap_get_server_banner());
+ add_header(t, "SERVER_PROTOCOL", r->protocol);
+ add_header(t, "SERVER_NAME", ap_get_server_name(r));
+ add_header(t, "SERVER_ADMIN", r->server->server_admin);
+ add_header(t, "SERVER_ADDR", r->connection->local_ip);
+ add_header(t, "SERVER_PORT", apr_psprintf(r->pool, "%u",
+ ap_get_server_port(r)));
+- add_header(t, "REMOTE_ADDR", r->connection->remote_ip);
++ add_header(t, "REMOTE_ADDR", r->useragent_ip);
+ add_header(t, "REMOTE_PORT", apr_psprintf(r->pool, "%d", port));
+ add_header(t, "REMOTE_USER", r->user);
+ add_header(t, "REQUEST_METHOD", r->method);