summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Hummel2023-09-29 06:16:48 -0700
committerDavid Hummel2023-09-29 06:16:48 -0700
commit9bd9a59227e450b29df499308e804cc15b7d3185 (patch)
tree3d79bba550b3b1a8a9b022652d7cd960ee61767c
parent959f7034116c61abbd95909d1384ae515d8575f1 (diff)
downloadaur-9bd9a59227e450b29df499308e804cc15b7d3185.tar.gz
Update pkgver, remove now-merged patches
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 2 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f718e0249849..9e4810460be1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mod_tile-git
pkgdesc = Mod tile is a daemon and apache module for rendering and serving Mapnik raster tiles
- pkgver = 0.6.1.r49.g672969f
+ pkgver = 0.6.1.r53.g3c86206
pkgrel = 1
url = https://github.com/openstreetmap/mod_tile
arch = i686
@@ -17,15 +17,11 @@ pkgbase = mod_tile-git
optdepends = ceph-libs: RADOS tile storage support
optdepends = libmemcached: Memcached tile storage support
source = git+https://github.com/openstreetmap/mod_tile.git
- source = mod_tile-use_ctest_rather_than_dart.patch::https://github.com/openstreetmap/mod_tile/pull/329.patch
- source = mod_tile-ctest_custom_test_ports.patch::https://github.com/openstreetmap/mod_tile/pull/331.patch
source = renderd.service
source = renderd-postgresql.service
source = renderd.sysusers
source = renderd.tmpfiles
sha256sums = SKIP
- sha256sums = 0e4e96161c07283af6df1dd16ba15f89361ac40881a7d68e1d5fe7feda6d1f0f
- sha256sums = e86717b6819b069d6d7dfeff87ee33bef4a38b17ea17f4944fcbb8b2da5db4c4
sha256sums = 7bb1c67f92e9d253cecbb2f17048fba151a67e470c231fc33605937917b0567a
sha256sums = d6c009e95380d8a9be41f0bd077638cb6adbebb74fff238a2bfc9fbbb3ed49fa
sha256sums = cd6871cdb3e640912c95499e97fe1a2496ba95f102ec65f112bcd546ba736514
diff --git a/PKGBUILD b/PKGBUILD
index 7734867312de..34da76374af3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: David Hummel <david dot hummel at gmail point com>
pkgname=('mod_tile-git' 'renderd-git')
-pkgver=0.6.1.r49.g672969f
+pkgver=0.6.1.r53.g3c86206
pkgrel=1
pkgdesc='Mod tile is a daemon and apache module for rendering and serving Mapnik raster tiles'
arch=('i686' 'x86_64')
@@ -13,15 +13,11 @@ optdepends=('ceph-libs: RADOS tile storage support'
'libmemcached: Memcached tile storage support')
makedepends=('apache' 'apr' 'cairo' 'cmake' 'git' 'glib2' 'iniparser' 'mapnik')
source=('git+https://github.com/openstreetmap/mod_tile.git'
- 'mod_tile-use_ctest_rather_than_dart.patch::https://github.com/openstreetmap/mod_tile/pull/329.patch'
- 'mod_tile-ctest_custom_test_ports.patch::https://github.com/openstreetmap/mod_tile/pull/331.patch'
'renderd.service'
'renderd-postgresql.service'
'renderd.sysusers'
'renderd.tmpfiles')
sha256sums=('SKIP'
- '0e4e96161c07283af6df1dd16ba15f89361ac40881a7d68e1d5fe7feda6d1f0f'
- 'e86717b6819b069d6d7dfeff87ee33bef4a38b17ea17f4944fcbb8b2da5db4c4'
'7bb1c67f92e9d253cecbb2f17048fba151a67e470c231fc33605937917b0567a'
'd6c009e95380d8a9be41f0bd077638cb6adbebb74fff238a2bfc9fbbb3ed49fa'
'cd6871cdb3e640912c95499e97fe1a2496ba95f102ec65f112bcd546ba736514'
@@ -32,12 +28,6 @@ pkgver() {
git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
}
-prepare() {
- cd mod_tile || exit
- patch -Np1 < ../mod_tile-use_ctest_rather_than_dart.patch
- patch -Np1 < ../mod_tile-ctest_custom_test_ports.patch
-}
-
build() {
cmake -B mod_tile_build -S mod_tile -DCMAKE_BUILD_TYPE:STRING=Release -DENABLE_TESTS:BOOL=ON
cmake --build mod_tile_build