summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Mensinger2018-10-15 14:19:32 +0200
committerDaniel Mensinger2018-10-15 14:19:32 +0200
commit067a4234a45fc0c838a1656a3cf777570a040ea3 (patch)
tree0d2681eb0b9604fdc803134e5975e98fc5a8c823
downloadaur-067a4234a45fc0c838a1656a3cf777570a040ea3.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d5df811b4b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = modbus-sma
+ pkgdesc = C++ library for accessing the the modbus interface of SMA inverters
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/mensinda/modbusSMA
+ arch = x86_64
+ license = Apache
+ makedepends = meson
+ makedepends = ninja
+ depends = libmodbus
+ depends = sqlite3
+ source = https://github.com/mensinda/modbusSMA/releases/download/v1.0.0/modbusSMA-src-v1.0.0.tar.gz
+ sha256sums = 1a1170f7c9db766289f304cab8e65c5421a720fd9ed7fab6ea4f7785625d90fc
+
+pkgname = modbus-sma
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8501e13fc1b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Daniel Mensinger <daniel@mensinger-ka.de>
+pkgname=modbus-sma
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="C++ library for accessing the the modbus interface of SMA inverters"
+arch=('x86_64')
+url="https://github.com/mensinda/modbusSMA"
+license=('Apache')
+depends=('libmodbus' 'sqlite3')
+makedepends=('meson' 'ninja')
+source=("https://github.com/mensinda/modbusSMA/releases/download/v${pkgver}/modbusSMA-src-v${pkgver}.tar.gz")
+sha256sums=('1a1170f7c9db766289f304cab8e65c5421a720fd9ed7fab6ea4f7785625d90fc')
+
+prepare() {
+ cd "modbusSMA"
+
+ [ -d build ] && rm -rf build
+}
+
+build() {
+ cd "modbusSMA"
+
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd "modbusSMA"
+
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+