summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolas Koesling2022-10-01 16:59:17 +0200
committerNikolas Koesling2022-10-01 16:59:17 +0200
commit1c042403c281f76ab26392161aa959d550b3f8f1 (patch)
tree7d2877225080007106d57707b6ecc9b4c06f0a14
downloadaur-1c042403c281f76ab26392161aa959d550b3f8f1.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26f85923be74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = modbus-tcp-client-shm
+ pkgdesc = modbus tcp client that stores its data (registers) in shared memory
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = https://github.com/NikolasK-source/modbus_tcp_client_shm
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ source = git+https://github.com/NikolasK-source/modbus_tcp_client_shm.git#tag=v1.2.3
+ sha256sums = SKIP
+
+pkgname = modbus-tcp-client-shm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65f1ab0075c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nikolas Koesling <nikolas@koesling.network>
+
+pkgname=modbus-tcp-client-shm
+pkgrel=1
+pkgver=1.2.3
+pkgdesc="modbus tcp client that stores its data (registers) in shared memory"
+url="https://github.com/NikolasK-source/modbus_tcp_client_shm"
+license=('MIT')
+arch=('x86_64' 'aarch64')
+makedepends=('cmake' 'git')
+source=("git+https://github.com/NikolasK-source/modbus_tcp_client_shm.git#tag=v${pkgver}")
+
+sha256sums=('SKIP')
+
+prepare() {
+ cd modbus_tcp_client_shm
+ git submodule init
+ git submodule update
+ mkdir -p build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCLANG_FORMAT=OFF -DCOMPILER_WARNINGS=OFF -B build .
+}
+
+build() {
+ cd modbus_tcp_client_shm
+ cmake --build build
+}
+
+package() {
+ cd modbus_tcp_client_shm
+ install -Dm755 build/modbus-tcp-client-shm "${pkgdir}/usr/bin/modbus-tcp-client-shm"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}