summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Kołosowski2019-01-09 18:44:58 +0100
committerTomasz Kołosowski2019-01-09 18:45:20 +0100
commit02451395fd54fa855756d67f1e7fa651a16044f1 (patch)
tree0578c8d64cb0117e06086bdcf26018ad2924daa8
parent5061357377778a0d41951e405b7087b9b5f099ac (diff)
downloadaur-02451395fd54fa855756d67f1e7fa651a16044f1.tar.gz
Updated to version 3.8.0
Removed changelog
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD26
-rw-r--r--changelog40
-rw-r--r--modelio.desktop4
4 files changed, 25 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1402209422c..feac38b3c693 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,25 @@
pkgbase = modelio-bin
pkgdesc = The opensource modeling environment
- pkgver = 3.6.1
+ pkgver = 3.8.0
pkgrel = 1
url = https://www.modelio.org/
- changelog = changelog
arch = i686
arch = x86_64
license = GPL3
- depends = libxtst
- depends = libstdc++5
- depends = webkitgtk2
depends = glib2
+ depends = java-runtime
+ depends = libx11
+ depends = libxtst
+ depends = webkit2gtk
optdepends = atk
optdepends = gtk2
optdepends = cairo
source = modelio.desktop
- source = changelog
- sha256sums = SKIP
- sha256sums = SKIP
- source_i686 = modelio-3.6.1-i686::https://sourceforge.net/projects/modeliouml/files/3.6.1/modelio-open-source-3.6.1_i386.deb/download
- sha256sums_i686 = SKIP
- source_x86_64 = modelio-3.6.1-x86_64::https://sourceforge.net/projects/modeliouml/files/3.6.1/modelio-open-source-3.6.1_amd64.deb/download
- sha256sums_x86_64 = SKIP
+ sha256sums = af7e10bb2849fb9cdb2ec0054d782dedd5c6901cbf3e742d1ab872447ae38b5c
+ source_i686 = modelio-3.8.0-i686.deb::https://sourceforge.net/projects/modeliouml/files/3.8.0/modelio-open-source3.8_3.8.0_i386.deb/download
+ sha256sums_i686 = 8cdc9b094807c509d943bcd1b88bbc3c5862c425799f19f05f796446447f3185
+ source_x86_64 = modelio-3.8.0-x86_64.deb::https://sourceforge.net/projects/modeliouml/files/3.8.0/modelio-open-source3.8_3.8.0_amd64.deb/download
+ sha256sums_x86_64 = 4d3252c0f611172c94d322cfa3e3257bb21adc9c2278f1e411bbbde0b5d21ded
pkgname = modelio-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4400bc3b26c4..7b3b655e2ced 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,10 @@
pkgname=modelio-bin
# Version
-pkgver=3.6.1
+_pkgvermajor=3
+_pkgverminor=8
+_pkgverpatch=0
+pkgver="${_pkgvermajor}.${_pkgverminor}.${_pkgverpatch}"
pkgrel=1
# Generic
@@ -18,7 +21,7 @@ license=('GPL3')
#groups=()
# Dependencies
-depends=('libxtst' 'libstdc++5' 'webkitgtk2' 'glib2')
+depends=('glib2' 'java-runtime' 'libx11' 'libxtst' 'webkit2gtk')
optdepends=('atk' 'gtk2' 'cairo')
#makedepends=()
#checkdepends=()
@@ -32,25 +35,22 @@ optdepends=('atk' 'gtk2' 'cairo')
#backup=()
#options=()
#install=modelio
-changelog=changelog
# Sources
-source=("modelio.desktop" "changelog")
-source_i686=("modelio-${pkgver}-i686::https://sourceforge.net/projects/modeliouml/files/${pkgver}/modelio-open-source-${pkgver}_i386.deb/download")
-source_x86_64=("modelio-${pkgver}-x86_64::https://sourceforge.net/projects/modeliouml/files/${pkgver}/modelio-open-source-${pkgver}_amd64.deb/download
-")
+source=("modelio.desktop")
+source_i686=("modelio-${pkgver}-i686.deb::https://sourceforge.net/projects/modeliouml/files/${pkgver}/modelio-open-source${_pkgvermajor}.${_pkgverminor}_${pkgver}_i386.deb/download")
+source_x86_64=("modelio-${pkgver}-x86_64.deb::https://sourceforge.net/projects/modeliouml/files/${pkgver}/modelio-open-source${_pkgvermajor}.${_pkgverminor}_${pkgver}_amd64.deb/download")
#noextract=()
#validpgpkeys=()
-sha256sums=('SKIP'
- 'SKIP')
-sha256sums_i686=('SKIP')
-sha256sums_x86_64=('SKIP')
+sha256sums=('af7e10bb2849fb9cdb2ec0054d782dedd5c6901cbf3e742d1ab872447ae38b5c')
+sha256sums_i686=('8cdc9b094807c509d943bcd1b88bbc3c5862c425799f19f05f796446447f3185')
+sha256sums_x86_64=('4d3252c0f611172c94d322cfa3e3257bb21adc9c2278f1e411bbbde0b5d21ded')
#pkgver() {
#}
prepare() {
- ar p modelio-${pkgver}-${CARCH} data.tar.gz | tar zx
+ ar p modelio-${pkgver}-${CARCH}.deb data.tar.xz | tar xJ
}
#build() {
@@ -63,5 +63,5 @@ package() {
install -dm755 "${pkgdir}/usr/share/applications/"
install -dm755 "${pkgdir}/opt/modelio"
install -Dm755 "${srcdir}/modelio.desktop" "${pkgdir}/usr/share/applications/"
- cp -r "${srcdir}"/usr/lib/modelio-open-source3.6/* "${pkgdir}/opt/modelio/"
+ cp -r "${srcdir}"/usr/lib/modelio-open-source${_pkgvermajor}.${_pkgverminor}/* "${pkgdir}/opt/modelio/"
}
diff --git a/changelog b/changelog
deleted file mode 100644
index 351eb673c232..000000000000
--- a/changelog
+++ /dev/null
@@ -1,40 +0,0 @@
-Changelog Modelio 3.6.1
-
-Evolutions:
-
- Improvement of the indexes management.
- Diagrams palette are now displayed in ‘icon’ mode by default.
- A diagram selection box now appears when creating a Related Diagram Link.
-
-Fixes / Improvements:
-
- Fixed issues with edition in diagrams when several diagrams are opened.
- Fixed issues with the XMI import/export.
- Fixed memory leaks in diagram editors.
- Fixed issue with integer values edition in the Properties view.
- Fixed issue with elements label display in ‘User defined image’ representation mode.
- Fixed issue with project export on MacOS.
-
-Notes:
-
-The Rich Note feature has been validated under the following platforms:
-
- Windows Seven SP1 and Windows 8.1 using the following ‘offices’:
- MS Office 2003 (32-bit only)
- MS Office 2007 (32 and 64-bit)
- MS Office 2010 (32 and 64-bit)
- MS Office 2013 (32 and 64-bit)
- OpenOffice 3.4.1 (32-bit only)
- LibreOffice 3.4.5 (32-bit only)
- LibreOffice 3.5.4 (32-bit only)
- LibreOffice 3.6.1 (32-bit only)
- LibreOffice 4.1.5 (32-bit only)
- LibreOffice 4.2.0 (32-bit only)
- Ubuntu 12.04 & 14.04 and CentOS 6 & 7 using the following ‘offices’:
- OpenOffice 3.3.0 (32 and 64-bit)
- LibreOffice 3.4.5 (32 and 64-bit)
- LibreOffice 3.5.4 (32 and 64-bit)
- LibreOffice 3.6.1 (32 and 64-bit)
- LibreOffice 4.1.3 (32-bit only)
-
-(Recommended versions are in bold) \ No newline at end of file
diff --git a/modelio.desktop b/modelio.desktop
index 7d9ac19de907..837aa75548ee 100644
--- a/modelio.desktop
+++ b/modelio.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
Name=Modelio
-Version=3.6.1
+Version=3.8.0
Comment=The opensource modeling environment
-Exec=/opt/modelio/modelio %u
+Exec=/opt/modelio/modelio.sh %u
Icon=/opt/modelio/icon.xpm
Type=Application
Categories=Development;UML;