summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryo2019-04-12 11:18:35 +0200
committeryo2019-04-12 11:18:35 +0200
commit0471161496d5a2aac0cce332f0347a8a581b93d6 (patch)
tree4872b9bfe0285f38326e458ffa718e5ef8ad5f39
downloadaur-0471161496d5a2aac0cce332f0347a8a581b93d6.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66404a01395f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = modfname
+ pkgdesc = file and folder name modifier on the all system
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/yoarch/modfname
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python>=3
+ source = https://files.pythonhosted.org/packages/source/m/modfname/modfname-1.0.1.tar.gz
+ sha256sums = ac10bde7ebdbc883639bb400b96c924878df87d23867ed2dff4455060da50688
+
+pkgname = modfname
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6a9b954b0ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cc8de5c56f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Yann Orieult <yo.managements@gmail.com>
+
+pkgname=modfname
+pkgver='1.0.1'
+pkgrel='1'
+pkgdesc='file and folder name modifier on the all system'
+arch=('any')
+url='https://github.com/yoarch/modfname'
+license=('MIT')
+depends=('python>=3')
+makedepends=('python' 'python-setuptools')
+
+source=("https://files.pythonhosted.org/packages/source/m/modfname/modfname-1.0.1.tar.gz")
+sha256sums=('ac10bde7ebdbc883639bb400b96c924878df87d23867ed2dff4455060da50688')
+#source#=("file:///$MHOME/dev/python/replacefs/dist/replacefs-1.1.0.tar.gz")
+#sha256sums#=("SKIP")
+
+build() {
+ cd $srcdir/$pkgname-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$pkgname-${pkgver}
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/lib/$pkgname/README.md"
+}