summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-09-21 01:29:36 -0400
committergraysky2015-09-21 01:29:36 -0400
commit89664bbcee273ae402b81bbde9456c7204a2aa82 (patch)
tree56448a4dd238d4006074078d7d69d56f327897b3
parent22c19791f844783064a6fb745a79cc7ffb893a12 (diff)
downloadaur-89664bbcee273ae402b81bbde9456c7204a2aa82.tar.gz
Update to 2.33-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--readme.install5
3 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fd0f4b24319..c7e029e50140 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = modprobed-db
pkgdesc = Keeps track of EVERY kernel module ever used - useful for those of us who make localmodconfig :)
- pkgver = 2.32
+ pkgver = 2.33
pkgrel = 1
url = https://wiki.archlinux.org/index.php/Modprobed-db
install = readme.install
arch = any
license = MIT
depends = kmod
- optdepends = sudo
+ optdepends = sudo: needed to recall modules via a call to modprobe
conflicts = modprobed_db
replaces = modprobed_db
- source = http://repo-ck.com/source/modprobed-db/modprobed-db-2.32.tar.xz
- sha256sums = 54f51be261b5e2603d078447c1375323fb49b8d6a1d53374b0451dbccc5494f2
+ source = http://repo-ck.com/source/modprobed-db/modprobed-db-2.33.tar.xz
+ sha256sums = 5f8a719088a8646b1f4b9f9d34b2f7110168137ae17b6d4b74c440b2f29d649e
pkgname = modprobed-db
diff --git a/PKGBUILD b/PKGBUILD
index 9374e82f6371..c6e4722c0acb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: graysky <graysky AT archlinux dot us>
pkgname=modprobed-db
-pkgver=2.32
+pkgver=2.33
pkgrel=1
pkgdesc='Keeps track of EVERY kernel module ever used - useful for those of us who make localmodconfig :)'
arch=('any')
license=('MIT')
depends=('kmod')
-optdepends=('sudo')
+optdepends=('sudo: needed to recall modules via a call to modprobe')
replaces=('modprobed_db')
conflicts=('modprobed_db')
url="https://wiki.archlinux.org/index.php/Modprobed-db"
source=("http://repo-ck.com/source/$pkgname/$pkgname-$pkgver.tar.xz")
-sha256sums=('54f51be261b5e2603d078447c1375323fb49b8d6a1d53374b0451dbccc5494f2')
+sha256sums=('5f8a719088a8646b1f4b9f9d34b2f7110168137ae17b6d4b74c440b2f29d649e')
install=readme.install
build() {
@@ -22,5 +22,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/readme.install b/readme.install
index 3842eeec2162..6ca0ec58ba7a 100644
--- a/readme.install
+++ b/readme.install
@@ -39,4 +39,9 @@ post_upgrade() {
echo '-->'
echo '--> Make sure you update your crontab accordingly.'
fi
+
+ if [ $(vercmp $2 2.33) -lt 0 ]; then
+ echo '--> The system service and timer have been deprecated in favor of user flavors.'
+ echo '--> See the manpage of modprobed for details.'
+ fi
}