summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntti Ellilä2024-04-24 00:11:28 +0300
committerAntti Ellilä2024-04-24 00:11:28 +0300
commitae547e14d9b35ae2ad4063ff82053e752d3541e4 (patch)
treebc04f46f4394898f555f9137c91bea5f66705c53
parentafadbd1509d413e018bba3bca2f70af5c3cd0816 (diff)
downloadaur-ae547e14d9b35ae2ad4063ff82053e752d3541e4.tar.gz
v0.7.0
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
-rwxr-xr-xmodrinth-app2
4 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 878de10540c1..25634274988d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = modrinth-app
pkgdesc = An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.
- pkgver = 0.6.3
- pkgrel = 2
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://modrinth.com/app
arch = x86_64
license = GPL3
@@ -22,12 +22,12 @@ pkgbase = modrinth-app
depends = libxext
depends = libxxf86vm
optdepends = xorg-xrandr: for older minecraft versions
- conflicts = modrinth-app-bin
- conflicts = modrinth-app-git
options = !lto
- source = modrinth-app-0.6.3.tar.gz::https://github.com/modrinth/theseus/archive/refs/tags/v0.6.3.tar.gz
+ source = modrinth-app-0.7.0.tar.gz::https://github.com/modrinth/theseus/archive/refs/tags/v0.7.0.tar.gz
source = modrinth-app.desktop
- sha256sums = b924ce16288f55b93ab26ec8511154d7e16fe38780065ea58082cb56bd045e8f
+ source = modrinth-app
+ sha256sums = ddcf965803ede4f730d3bf8d47c947899a7ff9e3ccf9261ba4e48848dc608627
sha256sums = ad8f7ffea0435881acdd7ecb560443e281982727dc7c715885367e9466bc0a62
+ sha256sums = 5404b4e7b25903afe43ab2f2451be4b27f4823c6785327b166f2faa519fa38a9
pkgname = modrinth-app
diff --git a/.gitignore b/.gitignore
index cc9f5fe833cd..e43636fd496e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!PKGBUILD
!.SRCINFO
!modrinth-app.desktop
+!modrinth-app
diff --git a/PKGBUILD b/PKGBUILD
index 7c7b6ef95132..aac9abc0bd6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Antti <antti@antti.codes>
pkgname=modrinth-app
-pkgver=0.6.3
-pkgrel=2
+pkgver=0.7.0
+pkgrel=1
pkgdesc='An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.'
url='https://modrinth.com/app'
arch=('x86_64')
@@ -17,13 +17,14 @@ depends=(
optdepends=(
'xorg-xrandr: for older minecraft versions'
)
-conflicts=('modrinth-app-bin' 'modrinth-app-git')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/modrinth/theseus/archive/refs/tags/v${pkgver}.tar.gz"
"modrinth-app.desktop"
+ "modrinth-app"
)
-sha256sums=('b924ce16288f55b93ab26ec8511154d7e16fe38780065ea58082cb56bd045e8f'
- 'ad8f7ffea0435881acdd7ecb560443e281982727dc7c715885367e9466bc0a62')
+sha256sums=('ddcf965803ede4f730d3bf8d47c947899a7ff9e3ccf9261ba4e48848dc608627'
+ 'ad8f7ffea0435881acdd7ecb560443e281982727dc7c715885367e9466bc0a62'
+ '5404b4e7b25903afe43ab2f2451be4b27f4823c6785327b166f2faa519fa38a9')
options=('!lto')
prepare() {
@@ -33,7 +34,7 @@ prepare() {
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
cd "theseus_gui"
- pnpm install --frozen-lockfile --no-optional
+ pnpm install --frozen-lockfile
}
build() {
@@ -55,7 +56,8 @@ check() {
}
package() {
- install -Dm755 "$srcdir"/theseus-"$pkgver"/target/release/theseus_gui "$pkgdir"/usr/bin/modrinth-app
+ install -Dm755 "$srcdir"/modrinth-app "$pkgdir"/usr/bin/modrinth-app
+ install -Dm755 "$srcdir"/theseus-"$pkgver"/target/release/theseus_gui "$pkgdir"/opt/modrinth-app/modrinth-app
install -Dm644 "$srcdir"/theseus-"$pkgver"/theseus_gui/src-tauri/icons/128x128.png "$pkgdir"/usr/share/icons/hicolor/128x128/apps/modrinth-app.png
install -Dm644 "$srcdir"/theseus-"$pkgver"/theseus_gui/src-tauri/icons/icon.png "$pkgdir"/usr/share/icons/hicolor/256x256@2/apps/modrinth-app.png
diff --git a/modrinth-app b/modrinth-app
new file mode 100755
index 000000000000..c94bb7e58012
--- /dev/null
+++ b/modrinth-app
@@ -0,0 +1,2 @@
+#!/bin/sh
+env WEBKIT_DISABLE_DMABUF_RENDERER=1 /opt/modrinth-app/modrinth-app "$@"