summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntti2023-08-12 20:23:45 +0300
committerAntti2023-08-12 20:24:04 +0300
commitca9631a02753fe8075097d3425a76690e710815b (patch)
tree3b73089e080a0707fb202eccb8431041f601b93a
parent4ccac81d65044b41d1c26562d5a72b4dd6bde522 (diff)
downloadaur-ca9631a02753fe8075097d3425a76690e710815b.tar.gz
some depends, better source
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD9
3 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index deb14990707a..cc6a2f1d9452 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = modrinth-app
pkgdesc = An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://modrinth.com/app
arch = x86_64
license = GPL3
makedepends = rust
makedepends = pnpm
+ depends = webkit2gtk
+ depends = openssl-1.1
conflicts = modrinth-app-bin
conflicts = modrinth-app-git
- source = git+https://github.com/modrinth/theseus#tag=v0.4.0
- sha256sums = SKIP
+ source = theseus.tar.gz::https://github.com/modrinth/theseus/archive/refs/tags/v0.4.0.tar.gz
+ sha256sums = 2ef378704702216a60e1bc7c3f804edc04a6bba9cd7d07db1a366a0f3782033a
pkgname = modrinth-app
diff --git a/.gitignore b/.gitignore
index 17a74ff10057..1e0f4309367d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,3 @@
pkg/
src/
-theseus/
+theseus*
diff --git a/PKGBUILD b/PKGBUILD
index 5dab009137e1..8a544589c33d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
pkgname=modrinth-app
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.'
url='https://modrinth.com/app'
arch=('x86_64')
license=('GPL3')
+depends=('webkit2gtk' 'openssl-1.1')
conflicts=('modrinth-app-bin' 'modrinth-app-git')
makedepends=('rust' 'pnpm')
-source=("git+https://github.com/modrinth/theseus#tag=v$pkgver")
-sha256sums=('SKIP')
+source=("theseus.tar.gz::https://github.com/modrinth/theseus/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('2ef378704702216a60e1bc7c3f804edc04a6bba9cd7d07db1a366a0f3782033a')
build() {
- cd "${srcdir}/theseus/theseus_gui/"
+ cd "${srcdir}/theseus-${pkgver}/theseus_gui/"
sed -i -E \
"s|\"targets\": \"all\"|\"targets\": \"deb\"|" \