summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntti2023-08-06 16:37:26 +0300
committerAntti2023-08-06 16:39:01 +0300
commit51785eec0553406e20425bd8574fbbe1ba395d29 (patch)
tree1ded047b3f5df0b17fe403354ea489bf63970def
downloadaur-51785eec0553406e20425bd8574fbbe1ba395d29.tar.gz
init, v0.5.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae19fce7cec8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = modrinth-app-bin
+ pkgdesc = An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://modrinth.com/app
+ arch = x86_64
+ license = GPL3
+ provides = modrinth-app
+ conflicts = modrinth-app
+ conflicts = modrinth-app-git
+ source = https://launcher-files.modrinth.com/versions/0.4.0/linux/modrinth-app_0.5.0_amd64.deb
+ sha256sums = d68a74e432cda2bf8a0d094bcd6641f8196e9d8de056d3bbfc45cc86c66311d6
+
+pkgname = modrinth-app-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..67eca153f00c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.zst
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c1dc5d3d0e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Antti <antti@antti.codes>
+
+pkgname=modrinth-app-bin
+pkgver=0.5.0
+_projectver=0.4.0
+pkgrel=1
+pkgdesc='An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.'
+url='https://modrinth.com/app'
+arch=('x86_64')
+license=('GPL3')
+provides=('modrinth-app')
+conflicts=('modrinth-app' 'modrinth-app-git')
+source=("https://launcher-files.modrinth.com/versions/$_projectver/linux/modrinth-app_${pkgver}_amd64.deb")
+sha256sums=('d68a74e432cda2bf8a0d094bcd6641f8196e9d8de056d3bbfc45cc86c66311d6')
+
+build() {
+ cd "$srcdir/"
+ tar xf data.tar.gz
+}
+
+package() {
+ cp -r "${srcdir}/usr/" "${pkgdir}"
+}