summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntti Ellilä2024-04-23 23:36:12 +0300
committerAntti Ellilä2024-04-23 23:36:12 +0300
commitc1dff36ae104f17f9788304a1a098942a8a80dca (patch)
treee0176ee97b7ea39919499c9bb734b62377c2064e
parentd0316d138ff09d88e6a271bbf994c00aae14a3e8 (diff)
downloadaur-c1dff36ae104f17f9788304a1a098942a8a80dca.tar.gz
v0.7.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
-rwxr-xr-xmodrinth-app2
3 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ea3ad83b7d7..5ac260f4895b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = modrinth-app-bin
pkgdesc = An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.
- pkgver = 0.6.3
- pkgrel = 2
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://modrinth.com/app
arch = x86_64
license = GPL3
@@ -22,8 +22,9 @@ pkgbase = modrinth-app-bin
optdepends = xorg-xrandr: for older minecraft versions
provides = modrinth-app
conflicts = modrinth-app
- conflicts = modrinth-app-git
- source = https://launcher-files.modrinth.com/versions/0.6.3/linux/modrinth-app_0.6.3_amd64.deb
- sha256sums = 453e72dfaaff9e6f74224227bc2c0d5bb66ff4b424f747dffebb5e80f0449b2c
+ source = https://launcher-files.modrinth.com/versions/0.7.0/linux/modrinth-app_0.7.0_amd64.deb
+ source = modrinth-app
+ sha256sums = 0a91ddf6328492c33a2aa63059d6c371fb7ed8e6ce172f715b4eb28ee8cb6124
+ sha256sums = 5404b4e7b25903afe43ab2f2451be4b27f4823c6785327b166f2faa519fa38a9
pkgname = modrinth-app-bin
diff --git a/PKGBUILD b/PKGBUILD
index d5b7fe184860..170184513bce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Antti <antti@antti.codes>
pkgname=modrinth-app-bin
-pkgver=0.6.3
-pkgrel=2
+pkgver=0.7.0
+pkgrel=1
pkgdesc='An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.'
url='https://modrinth.com/app'
arch=('x86_64')
@@ -17,9 +17,13 @@ optdepends=(
'xorg-xrandr: for older minecraft versions'
)
provides=('modrinth-app')
-conflicts=('modrinth-app' 'modrinth-app-git')
-source=("https://launcher-files.modrinth.com/versions/${pkgver}/linux/modrinth-app_${pkgver}_amd64.deb")
-sha256sums=('453e72dfaaff9e6f74224227bc2c0d5bb66ff4b424f747dffebb5e80f0449b2c')
+conflicts=('modrinth-app')
+source=(
+ "https://launcher-files.modrinth.com/versions/${pkgver}/linux/modrinth-app_${pkgver}_amd64.deb"
+ "modrinth-app"
+)
+sha256sums=('0a91ddf6328492c33a2aa63059d6c371fb7ed8e6ce172f715b4eb28ee8cb6124'
+ '5404b4e7b25903afe43ab2f2451be4b27f4823c6785327b166f2faa519fa38a9')
build() {
cd "$srcdir/"
@@ -28,4 +32,7 @@ build() {
package() {
cp -r "${srcdir}/usr/" "${pkgdir}"
+ mkdir -p "${pkgdir}/opt/modrinth-app"
+ mv "${pkgdir}/usr/bin/modrinth-app" "${pkgdir}/opt/modrinth-app/"
+ install -Dm755 "${srcdir}/modrinth-app" "${pkgdir}/usr/bin/"
}
diff --git a/modrinth-app b/modrinth-app
new file mode 100755
index 000000000000..c94bb7e58012
--- /dev/null
+++ b/modrinth-app
@@ -0,0 +1,2 @@
+#!/bin/sh
+env WEBKIT_DISABLE_DMABUF_RENDERER=1 /opt/modrinth-app/modrinth-app "$@"