summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoreleaserbot2023-09-22 13:20:41 +0000
committergoreleaserbot2023-09-22 13:20:41 +0000
commit5d54023ff4e85656ffd60ee0d60f653784074fa1 (patch)
treed28c1cedef975fee144fb389dbff63c4caa8b9b3
downloadaur-5d54023ff4e85656ffd60ee0d60f653784074fa1.tar.gz
Update to v1.0.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed66a35a8925
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mods-bin
+ pkgdesc = GPT-4 on the command line
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://charm.sh/
+ license = MIT
+ conflicts = mods
+ provides = mods
+ arch = aarch64
+ source_aarch64 = https://github.com/charmbracelet/mods/releases/download/v1.0.0/mods_1.0.0_Linux_arm64.tar.gz
+ sha256sums_aarch64 = 5e07957acfa819b2bf702cb6533aec881f7def52813560d5487640adc50c7208
+ arch = armv7h
+ source_armv7h = https://github.com/charmbracelet/mods/releases/download/v1.0.0/mods_1.0.0_Linux_arm.tar.gz
+ sha256sums_armv7h = 1fb8a7335a70f4ac2f11aac6cfe479d59b644e16f7ff325ad0e2831b217e4445
+ arch = i686
+ source_i686 = https://github.com/charmbracelet/mods/releases/download/v1.0.0/mods_1.0.0_Linux_i386.tar.gz
+ sha256sums_i686 = bc655591c18616288af0a22e15512d068434b4e6c1b92076c2d76f94bc8930d4
+ arch = x86_64
+ source_x86_64 = https://github.com/charmbracelet/mods/releases/download/v1.0.0/mods_1.0.0_Linux_x86_64.tar.gz
+ sha256sums_x86_64 = 8fb034c90eacee46455f18d96cadb45fd80467603ecb4256b8d3b95cac0a48dc
+
+pkgname = mods-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..252c4819f4e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# This file was generated by GoReleaser. DO NOT EDIT.
+# Maintainer: Toby Padilla <toby@charm.sh>
+
+pkgname='mods-bin'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='GPT-4 on the command line'
+url='https://charm.sh/'
+arch=('aarch64' 'armv7h' 'i686' 'x86_64')
+license=('MIT')
+provides=('mods')
+conflicts=('mods')
+
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/charmbracelet/mods/releases/download/v1.0.0/mods_1.0.0_Linux_arm64.tar.gz")
+sha256sums_aarch64=('5e07957acfa819b2bf702cb6533aec881f7def52813560d5487640adc50c7208')
+
+source_armv7h=("${pkgname}_${pkgver}_armv7h.tar.gz::https://github.com/charmbracelet/mods/releases/download/v1.0.0/mods_1.0.0_Linux_arm.tar.gz")
+sha256sums_armv7h=('1fb8a7335a70f4ac2f11aac6cfe479d59b644e16f7ff325ad0e2831b217e4445')
+
+source_i686=("${pkgname}_${pkgver}_i686.tar.gz::https://github.com/charmbracelet/mods/releases/download/v1.0.0/mods_1.0.0_Linux_i386.tar.gz")
+sha256sums_i686=('bc655591c18616288af0a22e15512d068434b4e6c1b92076c2d76f94bc8930d4')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/charmbracelet/mods/releases/download/v1.0.0/mods_1.0.0_Linux_x86_64.tar.gz")
+sha256sums_x86_64=('8fb034c90eacee46455f18d96cadb45fd80467603ecb4256b8d3b95cac0a48dc')
+
+package() {
+ # bin
+ install -Dm755 "./mods" "${pkgdir}/usr/bin/mods"
+ # license
+ mkdir -p "${pkgdir}/usr/share/licenses/mods/"
+ install -Dm644 ./LICENSE* "${pkgdir}/usr/share/licenses/mods/"
+ # completions
+ mkdir -p "${pkgdir}/usr/share/bash-completion/completions/"
+ mkdir -p "${pkgdir}/usr/share/zsh/site-functions/"
+ mkdir -p "${pkgdir}/usr/share/fish/vendor_completions.d/"
+ install -Dm644 "./completions/mods.bash" "${pkgdir}/usr/share/bash-completion/completions/mods"
+ install -Dm644 "./completions/mods.zsh" "${pkgdir}/usr/share/zsh/site-functions/_mods"
+ install -Dm644 "./completions/mods.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/mods.fish"
+}