summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-09-24 20:57:00 +0200
committerSefa Eyeoglu2020-09-24 20:57:00 +0200
commitfa4abd23287270989d590161ad26be2027d0c0fb (patch)
treea9dd788ecf6783506fb691fc468a2b66d9cc9159
downloadaur-fa4abd23287270989d590161ad26be2027d0c0fb.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..667a392cebd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = modulo-git
+ pkgdesc = Basic Cross-platform GUI Toolkit for Any Language
+ pkgver = r.
+ pkgrel = 1
+ url = https://github.com/federico-terzi/modulo
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ makedepends = git
+ makedepends = clang
+ depends = wxgtk2
+ provides = modulo
+ conflicts = modulo
+ source = modulo-git::git+https://github.com/federico-terzi/modulo.git#branch=dev
+ sha512sums = SKIP
+
+pkgname = modulo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5efcc326363f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_branch=dev
+pkgname=modulo-git
+pkgver=r.
+pkgrel=1
+pkgdesc="Basic Cross-platform GUI Toolkit for Any Language"
+arch=(x86_64)
+url="https://github.com/federico-terzi/modulo"
+license=("GPL3")
+depends=("wxgtk2")
+makedepends=("rust" "git" "clang")
+provides=(modulo)
+conflicts=(modulo)
+source=("${pkgname}::git+https://github.com/federico-terzi/modulo.git#branch=${_branch}")
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd "$_pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+check() {
+ cd "$pkgname"
+
+ cargo test --release # --locked # not available as of 2020/09/24
+}
+
+build() {
+ cd "$pkgname"
+
+ cargo build --release # --locked # not available as of 2020/09/24
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 "target/release/modulo" "${pkgdir}/usr/bin/modulo"
+
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/modulo/README.md"
+}