summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commit31493c734ea4b6abc488ee7369af49f5786c79b1 (patch)
treefd4a7c943225c9ce22a34548b90f094a4d9cf37a
downloadaur-31493c734ea4b6abc488ee7369af49f5786c79b1.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD28
-rw-r--r--moe.install20
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad8d2c688da0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = moe
+ pkgdesc = A powerful, 8-bit clean, text editor. Supports ISO-8859-15 and ASCII.
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://www.gnu.org/software/moe/moe.html
+ install = moe.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = texinfo
+ depends = ncurses
+ backup = etc/moerc
+ source = http://ftp.gnu.org/gnu/moe/moe-1.5.tar.gz
+ md5sums = 9657248473d04549d6e85e6d36a3e3c3
+
+pkgname = moe
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4388f4bdbce4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Contributor: Henning Garus <henning.garus@gmail.com>
+# Contributor: Patrik Hautala <phloyd@iki.fi>
+
+pkgname=moe
+pkgver=1.5
+pkgrel=1
+pkgdesc='A powerful, 8-bit clean, text editor. Supports ISO-8859-15 and ASCII.'
+arch=('i686' 'x86_64')
+url='http://www.gnu.org/software/moe/moe.html'
+license=('GPL')
+depends=('ncurses')
+makedepends=('texinfo')
+install=moe.install
+backup=('etc/moerc')
+source=(http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('9657248473d04549d6e85e6d36a3e3c3')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/moe.install b/moe.install
new file mode 100644
index 000000000000..70e73d319d22
--- /dev/null
+++ b/moe.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(moe.info.gz)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}