summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Fettes2021-01-12 22:44:27 +0800
committerTony Fettes2021-01-12 22:44:27 +0800
commit984d2d02d04fda0367f39ab6a6d5b59423c1b57b (patch)
tree993553a3a8cd4446b5e5d4611580a9cc9c71d2e6
parentd6eceafb9aa15e78a7f742a23321fc4b3f3f1cf1 (diff)
downloadaur-984d2d02d04fda0367f39ab6a6d5b59423c1b57b.tar.gz
Upstream changes repo location
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
-rw-r--r--moe-kde-git.install2
-rw-r--r--set_kdec_jomada.patch13
4 files changed, 17 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f4e143f73fc..4356d7428d6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = moe-kde-git
pkgdesc = A Light theme, with blur transparencies and red tones with gradients for KDE
- pkgver = r91.29c375c
+ pkgver = r11.b58cecf
pkgrel = 1
- url = https://www.opencode.net/jomada/moe-theme
+ url = https://gitlab.com/jomada/moe-theme
install = moe-kde-git.install
arch = any
license = GPL3
makedepends = git
optdepends = plasma-desktop: for a plasma desktop theme
optdepends = kvantum-qt5: for a Kvantum theme
- optdepends = mcmojave-circle-icon-theme-git: Default icon theme
- optdepends = tencent-icon-theme-git: Another excellent icon theme
- optdepends = sierrabreeze-kwin-decoration-git: KWin decoration
- optdepends = sierrabreeze-jomada-kwin-decoration: Default KWin decoration
optdepends = latte-dock-git: for a Latte dock layout
optdepends = plasma5-applets-virtual-desktop-bar-git: for Latte dock
optdepends = plasma5-applets-latte-sidebar-button: for Latte dock
@@ -22,10 +18,8 @@ pkgbase = moe-kde-git
optdepends = plasma5-applets-betterinlineclock: Better inline (Chili) Clock on Latte dock
provides = moe-kde
conflicts = moe-kde
- source = git+https://www.opencode.net/jomada/moe-theme.git
- source = set_kdec_jomada.patch
+ source = git+https://gitlab.com/jomada/moe-theme.git
sha256sums = SKIP
- sha256sums = 29bc08871a9dc8288a231153f4fb674bf9baa9fb9e8af0371fdd82358767395a
pkgname = moe-kde-git
diff --git a/PKGBUILD b/PKGBUILD
index bd0b67ffe93a..5e15eb2f88c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,14 @@
pkgname=moe-kde-git
_gitname=moe-theme
-pkgver=r91.29c375c
+pkgver=r11.b58cecf
pkgrel=1
pkgdesc='A Light theme, with blur transparencies and red tones with gradients for KDE'
arch=('any')
-url='https://www.opencode.net/jomada/moe-theme'
+url='https://gitlab.com/jomada/moe-theme'
license=('GPL3')
optdepends=('plasma-desktop: for a plasma desktop theme'
'kvantum-qt5: for a Kvantum theme'
- 'mcmojave-circle-icon-theme-git: Default icon theme'
- 'tencent-icon-theme-git: Another excellent icon theme'
- 'sierrabreeze-kwin-decoration-git: KWin decoration'
- 'sierrabreeze-jomada-kwin-decoration: Default KWin decoration'
'latte-dock-git: for a Latte dock layout'
'plasma5-applets-virtual-desktop-bar-git: for Latte dock'
'plasma5-applets-latte-sidebar-button: for Latte dock'
@@ -25,15 +21,8 @@ makedepends=('git')
provides=('moe-kde')
conflicts=('moe-kde')
install=${pkgname}.install
-source=("git+${url}.git"
- 'set_kdec_jomada.patch')
-sha256sums=('SKIP'
- '29bc08871a9dc8288a231153f4fb674bf9baa9fb9e8af0371fdd82358767395a')
-
-prepare() {
- cd ${_gitname}
- git apply ${srcdir}/set_kdec_jomada.patch
-}
+source=("git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
cd ${_gitname}
@@ -45,8 +34,8 @@ package() {
echo 'Installing color-schemes...'
install -dm755 "${pkgdir}/usr/share/color-schemes"
- cp Color-schemes/* "${pkgdir}/usr/share/color-schemes"
- cp "Moe-Dark color-schemes"/* "${pkgdir}/usr/share/color-schemes"
+ cp color-schemes/* "${pkgdir}/usr/share/color-schemes"
+ cp "Moe-Dark-color-schemes"/* "${pkgdir}/usr/share/color-schemes"
echo 'Installing desktoptheme...'
install -dm755 "${pkgdir}/usr/share/plasma/desktoptheme"
@@ -57,13 +46,18 @@ package() {
install -dm755 "${pkgdir}/usr/share/plasma/look-and-feel"
cp -r look-and-feel/* "${pkgdir}/usr/share/plasma/look-and-feel"
+ echo 'Installing aurorae themes'
+ install -dm755 "${pkgdir}/usr/share/aurorae/themes"
+ cp -r aurorae/* "${pkgdir}/usr/share/aurorae/themes"
+ cp -r MoeDark-aurorae/* "${pkgdir}/usr/share/aurorae/themes"
+
echo 'Installing Kvantum theme...'
install -dm755 "${pkgdir}/usr/share/Kvantum"
cp -r kvantum/* "${pkgdir}/usr/share/Kvantum"
- cp -r "Moe-Dark kvantum"/* "${pkgdir}/usr/share/Kvantum"
+ cp -r "Moe-Dark-kvantum"/* "${pkgdir}/usr/share/Kvantum"
echo 'Installing konsole theme...'
install -dm755 "${pkgdir}/usr/share/konsole"
cp konsole/* "${pkgdir}/usr/share/konsole"
- cp "Moe-Dark konsole"/* "${pkgdir}/usr/share/konsole"
+ cp "Moe-Dark-konsole"/* "${pkgdir}/usr/share/konsole"
}
diff --git a/moe-kde-git.install b/moe-kde-git.install
index 639a2d6cf0c9..6a5302754e92 100644
--- a/moe-kde-git.install
+++ b/moe-kde-git.install
@@ -2,7 +2,7 @@ post_install() {
echo 'Attention:'
echo ' Latte Dock layout for Moe theme is NOT installed.'
echo ' Please manually download it from'
- echo ' https://www.opencode.net/jomada/moe-theme/raw/master/Latte%20Layout/Moe.layout.latte'
+ echo ' https://gitlab.com/jomada/moe-theme/-/raw/master/latte-layout/Moe.layout.latte'
echo ' and import it by right-clicking your latte-dock and navigate to Layouts -> Manage Layouts...'
}
diff --git a/set_kdec_jomada.patch b/set_kdec_jomada.patch
deleted file mode 100644
index 1e3f9f083ff3..000000000000
--- a/set_kdec_jomada.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/look-and-feel/Moe/contents/defaults b/look-and-feel/Moe/contents/defaults
-index dc59ce5..8dd13bd 100644
---- a/look-and-feel/Moe/contents/defaults
-+++ b/look-and-feel/Moe/contents/defaults
-@@ -17,7 +17,7 @@ LayoutName=org.kde.breeze.desktop
- LayoutName=preview_stack
-
- [kwinrc][org.kde.kdecoration2]
--library=org.kde.sierrabreeze
-+library=org.kde.sierrabreezejomada
- theme=Brisa
-
- [plasmarc][Theme]