summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFiregem2021-12-04 17:27:12 -0500
committerFiregem2021-12-04 18:06:48 -0500
commitdef633e9f01fcfa1d4e1c3c2a7aac8835aa54c1b (patch)
tree982cc28dd773c3de329a4623f20dee6a88de1121
downloadaur-def633e9f01fcfa1d4e1c3c2a7aac8835aa54c1b.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e629799d4c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = moe-nim
+ pkgdesc = A command line based editor inspired by vim. Written in Nim.
+ pkgver = 0.2.8.0
+ pkgrel = 1
+ url = https://editor.moe
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = nim
+ makedepends = nimble
+ depends = glibc
+ optdepends = wl-clipboard: Clipboard support (Wayland)
+ optdepends = xsel: Clipboard support (x11)
+ optdepends = xclip: Clipboard support (x11)
+ conflicts = moe
+ source = moe-nim-0.2.8.0.tar.gz::https://github.com/fox0430/moe/archive/refs/tags/v0.2.8.0.tar.gz
+ sha256sums = 61343feb1fa451a3e7a505052c14bc33da5bbd6ab5cf6ae2b0289e70b5389b63
+
+pkgname = moe-nim
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a8e767c54ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Firegem <mrfiregem [at] protonmail [dot] ch>
+pkgname=moe-nim
+_pkgname=${pkgname%-nim}
+pkgver=0.2.8.0
+pkgrel=1
+pkgdesc='A command line based editor inspired by vim. Written in Nim.'
+arch=('x86_64')
+url='https://editor.moe'
+_gh='https://github.com/fox0430/moe'
+license=('GPL3')
+depends=('glibc')
+optdepends=(
+ 'wl-clipboard: Clipboard support (Wayland)'
+ 'xsel: Clipboard support (x11)'
+ 'xclip: Clipboard support (x11)'
+ )
+makedepends=('git' 'nim' 'nimble')
+conflicts=("$_pkgname")
+source=("${pkgname}-${pkgver}.tar.gz::${_gh}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('61343feb1fa451a3e7a505052c14bc33da5bbd6ab5cf6ae2b0289e70b5389b63')
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ nimble --nimbleDir:./.nimble refresh
+ nimble --nimbleDir:./.nimble install --depsOnly
+}
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ nimble --nimbleDir:./.nimble --localdeps release --skipUserCfg:on
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ install -Dm755 -t "${pkgdir}/usr/bin" moe
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" documents/*
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}/example" example/moerc.toml
+}