summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-11-07 20:09:39 -0600
committerLuis Martinez2021-11-07 20:09:39 -0600
commitd8b2632ea2584490575ff5c6e027ae61c889f13f (patch)
treee536d74f2530436fa1f58f73e63319d6d8df13e1
parentdcc016d5de9182815b85241d989ef8015c5541f1 (diff)
downloadaur-d8b2632ea2584490575ff5c6e027ae61c889f13f.tar.gz
package cleanup
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD32
2 files changed, 17 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8ddbc998517..940c7777b845 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = moebius
pkgdesc = Modern ANSI & ASCII Art Editor
pkgver = 1.0.29
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/blocktronics/moebius
arch = any
license = APACHE
makedepends = npm
depends = electron9
- provides = moebius
- source = https://github.com/blocktronics/moebius/archive/refs/tags/1.0.29.tar.gz
+ source = moebius-1.0.29.tar.gz::https://github.com/blocktronics/moebius/archive/1.0.29.tar.gz
source = moebius.sh
source = moebius.desktop
sha256sums = b0cdbc8d91ff07c5a826f6c2738f6aeaded4b397350422770a7b05f9ac60652b
- sha256sums = 99165de73de69f8d0ef67850d2b9b8f9c28d47eedd80730f7b7244a17f18f834
+ sha256sums = cb61d695dc8be325f2456929fb1503ce7d05e7f064fc422d8d81e41b049fe496
sha256sums = 3ec191df8ad9214ebe65716c21beaba36f54322c87d94f254190c0a29a75e674
pkgname = moebius
diff --git a/PKGBUILD b/PKGBUILD
index 59e979482c5a..d3e967767fcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,34 @@
-# Maintainer: grant0417 <grant0417@protonmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: grant0417 <grant0417@protonmail.com>
+
pkgname=moebius
pkgver=1.0.29
-pkgrel=1
+pkgrel=2
pkgdesc="Modern ANSI & ASCII Art Editor"
arch=('any')
url="https://github.com/blocktronics/moebius"
license=('APACHE')
depends=('electron9')
makedepends=('npm')
-provides=('moebius')
-source=("https://github.com/blocktronics/moebius/archive/refs/tags/$pkgver.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
"$pkgname.sh"
"$pkgname.desktop")
sha256sums=('b0cdbc8d91ff07c5a826f6c2738f6aeaded4b397350422770a7b05f9ac60652b'
- '99165de73de69f8d0ef67850d2b9b8f9c28d47eedd80730f7b7244a17f18f834'
+ 'cb61d695dc8be325f2456929fb1503ce7d05e7f064fc422d8d81e41b049fe496'
'3ec191df8ad9214ebe65716c21beaba36f54322c87d94f254190c0a29a75e674')
build() {
cd "$pkgname-$pkgver"
-
- electronVer=$(electron9 --version | tail -c +2)
-
+ _electronVer="$(</usr/lib/electron9/version)"
HOME="$srcdir/.electron-gyp" npm install --cache "${srcdir}/npm-cache"
- ./node_modules/.bin/electron-builder --linux --x64 --dir dist -c.electronDist=/usr/lib/electron9 -c.electronVersion=$electronVer
+ ./node_modules/.bin/electron-builder --linux --dir dist \
+ -c.electronDist=/usr/lib/electron9 -c.electronVersion="$_electronVer"
}
package() {
- cd "$pkgname-$pkgver"
-
- install -dm755 "${pkgdir}/usr/lib/${pkgname}"
- cp -dr --no-preserve=ownership dist/linux-unpacked/resources/* "${pkgdir}/usr/lib/${pkgname}/"
-
- install -dm755 "${pkgdir}/usr/bin"
- install -Dm755 "$srcdir/${pkgname}.sh" "$pkgdir/usr/bin/${pkgname}"
-
- install -Dm644 "$srcdir/${pkgname}.desktop" -t "$pkgdir/usr/share/applications"
+ install -D "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ install -Dm 644 "$pkgname.desktop" -t "$pkgdir/usr/share/applications/"
+ cd "$pkgname-$pkgver"
+ install -d "$pkgdir/usr/lib/$pkgname/"
+ cp -a --no-preserve=ownership dist/linux-unpacked/resources/* "$pkgdir/usr/lib/$pkgname/"
}