summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrant04172021-07-14 16:50:57 -0400
committergrant04172021-07-14 16:50:57 -0400
commitdcc016d5de9182815b85241d989ef8015c5541f1 (patch)
tree60fc3cbfb21b20a324ddebc0ba137ff4675cce8e
downloadaur-dcc016d5de9182815b85241d989ef8015c5541f1.tar.gz
Initial Commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--moebius.desktop8
-rw-r--r--moebius.sh3
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8ddbc998517
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = moebius
+ pkgdesc = Modern ANSI & ASCII Art Editor
+ pkgver = 1.0.29
+ pkgrel = 1
+ url = https://github.com/blocktronics/moebius
+ arch = any
+ license = APACHE
+ makedepends = npm
+ depends = electron9
+ provides = moebius
+ source = https://github.com/blocktronics/moebius/archive/refs/tags/1.0.29.tar.gz
+ source = moebius.sh
+ source = moebius.desktop
+ sha256sums = b0cdbc8d91ff07c5a826f6c2738f6aeaded4b397350422770a7b05f9ac60652b
+ sha256sums = 99165de73de69f8d0ef67850d2b9b8f9c28d47eedd80730f7b7244a17f18f834
+ sha256sums = 3ec191df8ad9214ebe65716c21beaba36f54322c87d94f254190c0a29a75e674
+
+pkgname = moebius
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59e979482c5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: grant0417 <grant0417@protonmail.com>
+pkgname=moebius
+pkgver=1.0.29
+pkgrel=1
+pkgdesc="Modern ANSI & ASCII Art Editor"
+arch=('any')
+url="https://github.com/blocktronics/moebius"
+license=('APACHE')
+depends=('electron9')
+makedepends=('npm')
+provides=('moebius')
+source=("https://github.com/blocktronics/moebius/archive/refs/tags/$pkgver.tar.gz"
+ "$pkgname.sh"
+ "$pkgname.desktop")
+sha256sums=('b0cdbc8d91ff07c5a826f6c2738f6aeaded4b397350422770a7b05f9ac60652b'
+ '99165de73de69f8d0ef67850d2b9b8f9c28d47eedd80730f7b7244a17f18f834'
+ '3ec191df8ad9214ebe65716c21beaba36f54322c87d94f254190c0a29a75e674')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ electronVer=$(electron9 --version | tail -c +2)
+
+ HOME="$srcdir/.electron-gyp" npm install --cache "${srcdir}/npm-cache"
+ ./node_modules/.bin/electron-builder --linux --x64 --dir dist -c.electronDist=/usr/lib/electron9 -c.electronVersion=$electronVer
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -dm755 "${pkgdir}/usr/lib/${pkgname}"
+ cp -dr --no-preserve=ownership dist/linux-unpacked/resources/* "${pkgdir}/usr/lib/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/bin"
+ install -Dm755 "$srcdir/${pkgname}.sh" "$pkgdir/usr/bin/${pkgname}"
+
+ install -Dm644 "$srcdir/${pkgname}.desktop" -t "$pkgdir/usr/share/applications"
+}
diff --git a/moebius.desktop b/moebius.desktop
new file mode 100644
index 000000000000..c03e3806d570
--- /dev/null
+++ b/moebius.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Moebius
+Comment=download songs from deezer
+Exec=moebius %U
+Terminal=false
+Type=Application
+Categories=Graphics;
+StartupWMClass=Moebius
diff --git a/moebius.sh b/moebius.sh
new file mode 100644
index 000000000000..2809fa4139cd
--- /dev/null
+++ b/moebius.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+exec electron9 /usr/lib/moebius/app.asar "$@"