summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWanesty2023-02-06 18:33:04 +0100
committerWanesty2023-02-06 18:33:04 +0100
commiteb8f48b63548a6808154390b865d4d6302e8afb3 (patch)
tree50c2dd9080edac40ee0317822725a2e569ebcf50
downloadaur-eb8f48b63548a6808154390b865d4d6302e8afb3.tar.gz
init x3
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD23
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f74822aebc82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = moebius-bin
+ pkgdesc = Modern ANSI & ASCII Art Editor
+ pkgver = 1.0.29
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/blocktronics/moebius
+ arch = x86_64
+ license = Apache
+ makedepends = libarchive
+ depends = gtk3
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ depends = xdg-utils
+ depends = libappindicator-gtk3
+ conflicts = moebius
+ noextract = Moebius.rpm
+ source = https://github.com/blocktronics/moebius/releases/download/1.0.29/Moebius.rpm
+ sha256sums = 69aaa1e42e287ed78c8e73971dae3df23ae4fa00e3416ea0fc262b7d147fefec
+
+pkgname = moebius-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b4669bfba0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Wanesty <github.com/Wanesty/aurpkg>
+# Dev: Andy 'Blocktronics' Herbert <blocktronics.org>
+
+pkgname=moebius-bin
+pkgver=1.0.29
+pkgrel=1
+epoch=1
+pkgdesc="Modern ANSI & ASCII Art Editor"
+arch=('x86_64')
+url="https://github.com/blocktronics/moebius"
+license=('Apache')
+depends=('gtk3' 'libnotify' 'libxss' 'libxtst' 'xdg-utils' 'libappindicator-gtk3')
+makedepends=('libarchive')
+conflicts=('moebius')
+source=("https://github.com/blocktronics/moebius/releases/download/$pkgver/Moebius.rpm")
+sha256sums=(69aaa1e42e287ed78c8e73971dae3df23ae4fa00e3416ea0fc262b7d147fefec)
+noextract=("Moebius.rpm")
+
+package() {
+ bsdtar -C "${pkgdir}" -xvf "$srcdir/Moebius.rpm"
+ mkdir "$pkgdir/usr/bin"
+ ln -s "/opt/Moebius/moebius" "$pkgdir/usr/bin/moebius"
+}