summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeke Sonxx2016-07-10 18:29:30 -0400
committerZeke Sonxx2016-07-10 18:30:10 -0400
commit8613e39938c5e902ed3cfd7178a85639abad41e0 (patch)
tree8093714cf8a05d0c405493a6e507e0e813f19373
downloadaur-8613e39938c5e902ed3cfd7178a85639abad41e0.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD36
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bd8862ec5c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = moeditor-bin
+ pkgdesc = All-purpose markdown editor based on Electrum
+ pkgver = 0.0.1_alpha
+ pkgrel = 1
+ url = https://github.com/Moeditor/Moeditor
+ arch = x86_64
+ license = GPL3
+ depends = gtk2
+ depends = libxss
+ depends = libxtst
+ depends = alsa-lib
+ depends = nss
+ depends = gconf
+ source = https://github.com/Moeditor/Moeditor/releases/download/v0.0.1-alpha/Moeditor-0.0.1-linux-x64.7z
+ md5sums = fe7e9970563f8bfd3e358f5893bdb41a
+ sha512sums = 696c91e7dbba2311ba3944cf93c4a3763d6d9a4fb0d5dd74b7fd4733964c272f338398ce00dcf2dcfe73cc906b1be9a914359ac4a4c1547e016912888efd4afe
+
+pkgname = moeditor-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..129e0a2c33d1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Arch stuff
+pkg/*
+src/*
+*.pkg.tar*
+
+
+# Moeditor source files
+*.7z
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e84db4879f9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Zeke Sonxx <zeke@zekesonxx.com>
+pkgname=moeditor-bin
+pkgver=0.0.1_alpha
+pkgrel=1
+epoch=
+pkgdesc="All-purpose markdown editor based on Electrum"
+arch=('x86_64')
+url="https://github.com/Moeditor/Moeditor"
+license=('GPL3')
+groups=()
+depends=('gtk2' 'libxss' 'libxtst' 'alsa-lib' 'nss' 'gconf')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/Moeditor/Moeditor/releases/download/v0.0.1-alpha/Moeditor-0.0.1-linux-x64.7z")
+noextract=()
+md5sums=('fe7e9970563f8bfd3e358f5893bdb41a')
+sha512sums=('696c91e7dbba2311ba3944cf93c4a3763d6d9a4fb0d5dd74b7fd4733964c272f338398ce00dcf2dcfe73cc906b1be9a914359ac4a4c1547e016912888efd4afe')
+validpgpkeys=()
+
+package() {
+ mkdir -p "$pkgdir/usr"
+ cp -r "$srcdir/usr/" "$pkgdir/"
+}