summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSasasu2016-08-19 23:27:49 +0800
committerSasasu2016-08-19 23:27:49 +0800
commit1981f2458fbdcb9314adbc265f08641f4bf2acda (patch)
tree6d61030ffcf1cb50fb33d6218065ba54b4b71feb
downloadaur-moefmcmd.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e21896168ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = moefmcmd
+ pkgdesc = moe.fm bash script client
+ pkgver = 20160819
+ pkgrel = 1
+ url = https://github.com/mike2718/moefmcmd.git
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = mpg123
+ depends = curl
+ depends = jq
+ source = moefmcmd::git+https://github.com/mike2718/moefmcmd.git
+ md5sums = SKIP
+
+pkgname = moefmcmd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b862e076287f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#Package from: mike2718 <https://github.com/mike2718>
+#Maintainer : Sasasu <lizhaolong0123@gmail.com>
+pkgname=moefmcmd
+pkgver=20160819
+pkgrel=1
+pkgdesc="moe.fm bash script client"
+arch=('any')
+url="https://github.com/mike2718/moefmcmd.git"
+license=('unknown')
+depends=('mpg123' 'curl' 'jq')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/mike2718/moefmcmd.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir"/"$_pkgname/$pkgname"
+ cp moefmcmd.sh moefmcmd
+}
+package() {
+ cd "$srcdir"/"$_pkgname/$pkgname"
+ mkdir -p "$pkgdir"/usr/bin
+ install -Dm755 "moefmcmd" "$pkgdir"/usr/bin
+}