summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 21:57:22 +0200
committeroli2015-06-12 21:57:22 +0200
commit3b81c527cf3012d1b67b463bc17428229a3bbcaf (patch)
treef83294ea2b37edee9e751432d7bee11add48b907
downloadaur-3b81c527cf3012d1b67b463bc17428229a3bbcaf.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfe549420347
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mofilereader
+ pkgdesc = API that lets you read .mo-Files and use their content just as you would do with GNUs gettext
+ pkgver = 0.1.2
+ pkgrel = 2
+ url = http://code.google.com/p/mofilereader/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ source = http://mofilereader.googlecode.com/files/moFileReader.0.1.2.zip
+ source = http://wiki.rigsofrods.com/images/1/1f/MoFR.patch
+ md5sums = 768b2e118c1e845622593e7c4b76777b
+ md5sums = 94ed75c7e1a8a419099a7ef72025985a
+
+pkgname = mofilereader
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a677d3e0c8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=mofilereader
+pkgver=0.1.2
+pkgrel=2
+pkgdesc="API that lets you read .mo-Files and use their content just as you would do with GNUs gettext"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/mofilereader/"
+makedepends=('cmake')
+license=('MIT')
+source=(http://mofilereader.googlecode.com/files/moFileReader.${pkgver}.zip
+http://wiki.rigsofrods.com/images/1/1f/MoFR.patch)
+md5sums=('768b2e118c1e845622593e7c4b76777b'
+ '94ed75c7e1a8a419099a7ef72025985a')
+
+build() {
+ cd $srcdir/src
+ patch -p0 < ../MoFR.patch
+ cd ../build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCOMPILE_DLL=ON .
+ make -j2
+}
+
+package() {
+ mkdir -p $pkgdir/usr/include
+ cd $srcdir/
+ install -D -m644 lib/libmoFileReader.so $pkgdir/usr/lib/libmoFileReader.so
+ install -D -m644 include/* $pkgdir/usr/include/
+}