summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiego Cano2018-10-19 18:46:40 +0200
committerDiego Cano2018-10-19 18:46:40 +0200
commit2d217d6177090b7211d54f80fce44c92f2781770 (patch)
tree0135ec0c753966b5f377035b7b83ac60adcb6be1
downloadaur-2d217d6177090b7211d54f80fce44c92f2781770.tar.gz
Created the PKGBUILD
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD53
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3593b69f85c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = moksha-git
+ pkgdesc = A fork of the E17 window manager used by Bodhi Linux, git version.
+ pkgver = r16221.288d897d3
+ pkgrel = 1
+ url = http://mokshadesktop.org
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = desktop-file-utils
+ depends = e_dbus
+ depends = efl>1.18
+ depends = xcb-util-keysyms
+ optdepends = acpid: power events on laptop lid close
+ optdepends = bc: calculator in everything module
+ optdepends = connman: network module
+ optdepends = doxygen: build documentation
+ optdepends = evas_generic_loaders: provide support for SVG icons
+ optdepends = gdb: create backtraces on crash
+ optdepends = geoclue2: geolocation module
+ provides = moksha
+ conflicts = moksha
+ conflicts = enlightenment
+ source = moksha::git+https://github.com/JeffHoogland/moksha.git
+ md5sums = SKIP
+
+pkgname = moksha-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a51cdd51ec96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Diego Cano <dcano@bleptstudio.es>
+pkgname=moksha-git
+pkgver=r16221.288d897d3
+pkgrel=1
+pkgdesc="A fork of the E17 window manager used by Bodhi Linux, git version."
+arch=('i686' 'x86_64')
+url="http://mokshadesktop.org"
+license=('BSD')
+depends=('desktop-file-utils' 'e_dbus' 'efl>1.18' 'xcb-util-keysyms')
+makedepends=('git')
+optdepends=('acpid: power events on laptop lid close'
+ 'bc: calculator in everything module'
+ 'connman: network module'
+ 'doxygen: build documentation'
+ 'evas_generic_loaders: provide support for SVG icons'
+ 'gdb: create backtraces on crash'
+ 'geoclue2: geolocation module')
+provides=('moksha')
+conflicts=("moksha" "enlightenment")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname%-git}::git+https://github.com/JeffHoogland/${pkgname%-git}.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}