summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Maftei2018-05-24 10:45:03 +0300
committerDan Maftei2018-05-24 10:45:03 +0300
commit1a85039531a70e420460ce9e9e5a5c7cbc4da470 (patch)
treeb3d63797fc8e3ee987d8cd88c5aa2869bb1f259e
parentd501d1e420d582b05e1dd98a72c40864ea208abc (diff)
downloadaur-1a85039531a70e420460ce9e9e5a5c7cbc4da470.tar.gz
Fixed a compilation error on newer gfortran (rdchx.f).
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
-rw-r--r--rdchx.patch11
3 files changed, 24 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 497f90cddf4f..061181f914cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,7 +18,9 @@ pkgbase = molden
optdepends = wget: to fetch PDB from rcsb.org
provides = molden
source = ftp://ftp.cmbi.ru.nl/pub/molgraph/molden/molden5.7.tar.gz
+ source = rdchx.patch
md5sums = 1b33fc2fda6429f1945ffa3c291ccd97
+ md5sums = 902d3fc3ebdb928fac38deb2ba7d5f94
pkgname = molden
diff --git a/PKGBUILD b/PKGBUILD
index 4b79f9a3306a..0c4ca8580f7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,15 +27,24 @@ backup=()
options=()
install=
changelog=
-source=(ftp://ftp.cmbi.ru.nl/pub/molgraph/molden/$pkgname$pkgver.tar.gz)
+source=(
+ "ftp://ftp.cmbi.ru.nl/pub/molgraph/molden/$pkgname$pkgver.tar.gz"
+ "rdchx.patch"
+)
noextract=()
-md5sums=('1b33fc2fda6429f1945ffa3c291ccd97')
+md5sums=('1b33fc2fda6429f1945ffa3c291ccd97'
+ '902d3fc3ebdb928fac38deb2ba7d5f94')
build() {
cd "$pkgname$pkgver"
# Patch Makefile for surf utility to reflect the
# replacement of missing makedepend
sed -i 's/@.*makedepend.*$/@ \$(CC) \$(INCLUDE) -M \$(SRCS) \> makedep/' surf/Makefile
+
+ # Patch rdchx.f for iconn dimension,
+ # thanks Panadestein for pointing out and
+ # arjun_karol for the solution
+ patch -p0 -i rdchx.patch
make
}
diff --git a/rdchx.patch b/rdchx.patch
new file mode 100644
index 000000000000..a323a731d20b
--- /dev/null
+++ b/rdchx.patch
@@ -0,0 +1,11 @@
+--- rdchx.f 2017-09-20 16:39:46.000000000 +0300
++++ rdchx.f.new 2018-05-24 10:38:11.820760091 +0300
+@@ -6016,7 +6016,7 @@
+ subroutine flth(iat,icnn,ibnds,iconn)
+ implicit double precision (a-h,p-z),integer (i-n),logical (o)
+ parameter (mxcon=10)
+- dimension iconn(mxcon+1,*),icnn(mxcon+1)
++ dimension iconn(mxcon,*),icnn(mxcon)
+
+ ibnds = 0
+ do i=1,iconn(1,iat)