summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2017-09-04 10:55:05 +0200
committerMorten Linderud2017-09-04 10:55:05 +0200
commit19d5a2728674b043fa4a4c2669f006c3cf72518e (patch)
treed1880682702d5cf940cc4f81e073bd79551d1cf6
parentc7d8570fbb00d69ef75c30f8fc74037c7f5ccf3a (diff)
downloadaur-19d5a2728674b043fa4a4c2669f006c3cf72518e.tar.gz
upgpkg: molecule 2.0.0.rc12-5
Fixed molecule Signed-off-by: Morten Linderud <morten@linderud.pw>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 909ca0866a15..e079c6a38072 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jul 30 19:24:12 UTC 2017
+# Mon Sep 4 08:55:10 UTC 2017
pkgbase = molecule
pkgdesc = Molecule aids in the development and testing of Ansible roles.
pkgver = 2.0.0.rc12
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/metacloud/molecule/tree/2.0.0.rc12
arch = any
license = MIT
@@ -16,6 +16,7 @@ pkgbase = molecule
depends = python-jinja
depends = python-marshmallow
depends = python-gilt
+ depends = python
depends = python-tabulate
depends = python-pbr
depends = python-pexpect
diff --git a/PKGBUILD b/PKGBUILD
index c4f0a569e1cf..29e1a3b1b352 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Morten Linderud <morten@linderud.pw>
pkgname="molecule"
pkgver=2.0.0.rc12
-pkgrel=4
+pkgrel=5
pkgdesc='Molecule aids in the development and testing of Ansible roles.'
url='https://github.com/metacloud/molecule/tree/2.0.0.rc12'
arch=('any')
license=('MIT')
makedepends=('python' 'python-setuptools')
depends=('ansible-lint' 'python-ansible' 'python-colorama' 'flake8'
- 'python-jinja' 'python-marshmallow' 'python-gilt'
+ 'python-jinja' 'python-marshmallow' 'python-gilt' 'python'
'python-tabulate' 'python-pbr' 'python-pexpect' 'python-cookiecutter'
'python-yaml' 'python-sh' 'python-click' 'yamllint' 'python-anyconfig')
optdepends=('python-docker: docker driver'
@@ -26,6 +26,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ft=sh ts=2 sw=2 et: