summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2017-09-06 02:05:34 +0200
committerMorten Linderud2017-09-06 02:05:34 +0200
commit33409fc25ce831878109578bd4df302aa2a671b5 (patch)
tree89a3bffb329d2d0e36d1cb991e453d440a5631e5
parent94f9644a2d71a125b6112660328e7e1f18af4b6b (diff)
downloadaur-33409fc25ce831878109578bd4df302aa2a671b5.tar.gz
upgpkg: molecule 2.0.4-2
molecule: added tox tests Signed-off-by: Morten Linderud <morten@linderud.pw>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cef7050be5d..0e10286bb392 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
# Generated by mksrcinfo v8
-# Tue Sep 5 18:51:33 UTC 2017
+# Wed Sep 6 00:05:35 UTC 2017
pkgbase = molecule
pkgdesc = aids in the development and testing of Ansible roles.
pkgver = 2.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/metacloud/molecule/tree/2.0.0.rc12
arch = any
license = MIT
+ checkdepends = python
+ checkdepends = python-tox
makedepends = python
makedepends = python-setuptools
depends = ansible-lint
diff --git a/PKGBUILD b/PKGBUILD
index 5bea81a3e754..b412d4e72e01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Morten Linderud <morten@linderud.pw>
pkgname="molecule"
pkgver=2.0.4
-pkgrel=1
+pkgrel=2
_commit=303337927095ab09957fca03ad145f176d0acb0c
pkgdesc='aids in the development and testing of Ansible roles.'
url='https://github.com/metacloud/molecule/tree/2.0.0.rc12'
@@ -13,6 +13,7 @@ depends=('ansible-lint' 'python-ansible' 'python-colorama' 'flake8'
'python-tabulate' 'python-pbr' 'python-pexpect' 'python-cookiecutter'
'python-yaml' 'python-sh' 'python-click' 'python-click-completion'
'python-tree-format-git' 'yamllint' 'python-anyconfig')
+checkdepends=('python' 'python-tox')
optdepends=('python-docker: docker driver'
'python-boto: EC2 driver'
'python-vagrant: vagrant driver'
@@ -26,6 +27,11 @@ build() {
python setup.py build
}
+check(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ tox -e py2,py3
+}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
export PBR_VERSION="${pkgver}"