summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2018-03-22 10:14:45 +0100
committerMorten Linderud2018-03-22 10:14:45 +0100
commitb1df1a0ade527ba01c28752f5c965314f0450fc8 (patch)
tree5166b3930114f324d611dc62ea4248e654624180
parent33409fc25ce831878109578bd4df302aa2a671b5 (diff)
downloadaur-b1df1a0ade527ba01c28752f5c965314f0450fc8.tar.gz
upgpkg: molecule 2.11-1
upstream release Updated molecule Signed-off-by: Morten Linderud <morten@linderud.pw>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e10286bb392..9f97792ff8c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Wed Sep 6 00:05:35 UTC 2017
+# Thu Mar 22 09:14:45 UTC 2018
pkgbase = molecule
pkgdesc = aids in the development and testing of Ansible roles.
- pkgver = 2.0.4
- pkgrel = 2
- url = https://github.com/metacloud/molecule/tree/2.0.0.rc12
+ pkgver = 2.11
+ pkgrel = 1
+ url = https://github.com/metacloud/molecule
arch = any
license = MIT
checkdepends = python
@@ -34,8 +34,8 @@ pkgbase = molecule
optdepends = python-boto: EC2 driver
optdepends = python-vagrant: vagrant driver
optdepends = python-shade: openstack driver
- source = molecule-2.0.4::git://github.com/metacloud/molecule.git#commit=303337927095ab09957fca03ad145f176d0acb0c
- sha256sums = SKIP
+ source = molecule-2.11.tar.gz::https://github.com/metacloud/molecule/archive/2.11.tar.gz
+ sha256sums = 3690abe30d280799018d70f94a7c9a063bd409dec2d7d5324e0962d7329ed0dc
pkgname = molecule
diff --git a/PKGBUILD b/PKGBUILD
index b412d4e72e01..a3971c6a335d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
# Maintainer: Morten Linderud <morten@linderud.pw>
pkgname="molecule"
-pkgver=2.0.4
-pkgrel=2
-_commit=303337927095ab09957fca03ad145f176d0acb0c
+pkgver=2.11
+pkgrel=1
pkgdesc='aids in the development and testing of Ansible roles.'
-url='https://github.com/metacloud/molecule/tree/2.0.0.rc12'
+url='https://github.com/metacloud/molecule'
arch=('any')
license=('MIT')
makedepends=('python' 'python-setuptools')
@@ -18,8 +17,8 @@ optdepends=('python-docker: docker driver'
'python-boto: EC2 driver'
'python-vagrant: vagrant driver'
'python-shade: openstack driver')
-source=("${pkgname}-${pkgver}::git://github.com/metacloud/molecule.git#commit=${_commit}")
-sha256sums=('SKIP')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/metacloud/molecule/archive/${pkgver}.tar.gz")
+sha256sums=('3690abe30d280799018d70f94a7c9a063bd409dec2d7d5324e0962d7329ed0dc')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -29,7 +28,7 @@ build() {
check(){
cd "${srcdir}/${pkgname}-${pkgver}"
- tox -e py2,py3
+ tox -e py3
}
package() {