summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2018-03-27 14:02:53 -0400
committerEric Berquist2018-03-27 14:02:53 -0400
commit7e41e3f4bab66c3eb0bef612c86d5f7d724821af (patch)
tree258460fe89446d513198b820f06d82be5c5b4f59
parent45369c6300dc1e740f8871ba7513efb9128d6c5e (diff)
downloadaur-7e41e3f4bab66c3eb0bef612c86d5f7d724821af.tar.gz
COPYING -> LICENSE, fix versioning
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0b14688d772..38bf5f7d6979 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 1 01:00:58 UTC 2016
+# Tue Mar 27 18:02:29 UTC 2018
pkgbase = molequeue-git
pkgdesc = Desktop integration of high performance computing resources
- pkgver = 0.8.0.r792.0d6fbba
- pkgrel = 3
+ pkgver = 0.9.0.r813.efcca96
+ pkgrel = 2
url = http://www.openchemistry.org/projects/molequeue
arch = i686
arch = x86_64
diff --git a/.gitignore b/.gitignore
index 68581b04417f..1b71d10134ff 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,7 @@
# makepkg files
pkg/
src/
+*.log
*.xz
# source files
diff --git a/PKGBUILD b/PKGBUILD
index cbfecc7bbec9..23b3aec7699a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=molequeue
pkgname="${_pkgname}-git"
-pkgver=0.8.0.r792.0d6fbba
-pkgrel=3
+pkgver=0.9.0.r813.efcca96
+pkgrel=2
pkgdesc="Desktop integration of high performance computing resources"
url="http://www.openchemistry.org/projects/molequeue"
arch=("i686" "x86_64")
@@ -17,9 +17,8 @@ sha256sums=("SKIP")
pkgver() {
cd "${srcdir}/${_pkgname}"
- _parent_ver=$(git log --tags --simplify-by-decoration --pretty="format:%d" | head -n 1 | cut -d " " -f 3 | tr -d ")" | tr -d v)
printf "%s.r%s.%s" \
- "${_parent_ver}" \
+ "$(git describe --tags --abbrev=0)" \
"$(git rev-list --count HEAD)" \
"$(git rev-parse --short HEAD)"
}
@@ -30,14 +29,19 @@ build() {
-DCMAKE_BUILD_TYPE:STRING=Release \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_INSTALL_LIBDIR:PATH=lib \
- -DENABLE_TESTING:BOOL=OFF \
+ -DENABLE_TESTING:BOOL=ON \
-DBUILD_SHARED_LIBS:BOOL=ON \
.
make
}
+check() {
+ cd "${srcdir}/${_pkgname}"
+ make test
+}
+
package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
- install -D -m 644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}