summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Hardy2016-03-12 12:58:16 +1100
committerJoshua Hardy2016-03-12 12:58:16 +1100
commita8499f9f9a0edb3b9edfb54f3391249212870c4d (patch)
treebdeb856b2cd97541aa45d972193d9cb1259a6ee7
downloadaur-a8499f9f9a0edb3b9edfb54f3391249212870c4d.tar.gz
initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD38
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..257da2c074c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = molprobity-git
+ pkgdesc = All-atom structure validation for macromolecular crystallography
+ pkgver = r1013.ee5bdd4
+ pkgrel = 1
+ url = http://molprobity.biochem.duke.edu/
+ arch = any
+ license = BSD
+ makedepends = python2
+ makedepends = git
+ makedepends = subversion
+ makedepends = curl
+ makedepends = tar
+ makedepends = make
+ makedepends = gawk
+ depends = python
+ depends = php
+ depends = lib32-libxext
+ depends = java-environment
+ depends = ucsf-chimera
+ depends = lib32-gcc-libs
+ depends = boost-libs
+ depends = tcsh
+ depends = lib32-libxt
+ provides = molprobity-git
+ conflicts = molprobity-git
+ options = !strip
+ source = molprobity-git::git+https://github.com/rlabduke/MolProbity#branch=molprobity_4.2
+ md5sums = SKIP
+
+pkgname = molprobity-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6e164cf8825
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Joshua Hardy joshinsilico
+pkgname=molprobity-git
+pkgver=r1013.ee5bdd4
+pkgrel=1
+pkgdesc="All-atom structure validation for macromolecular crystallography"
+arch=('any')
+url="http://molprobity.biochem.duke.edu/"
+license=('BSD')
+depends=('python' 'php' 'lib32-libxext' 'java-environment' 'ucsf-chimera' 'lib32-gcc-libs' 'boost-libs' 'tcsh' 'lib32-libxt')
+makedepends=('python2' 'git' 'subversion' 'curl' 'tar' 'make' 'gawk')
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}")
+options=('!strip')
+source=('molprobity-git::git+https://github.com/rlabduke/MolProbity#branch=molprobity_4.2')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-VCS}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-VCS}"
+ sed -i -e s:"python ../sources/cctbx_project/libtbx/configure.py mmtbx":"python2 ../sources/cctbx_project/libtbx/configure.py mmtbx":g configure.sh
+}
+
+build() {
+ cd "$srcdir/${pkgname%-VCS}"
+ ./configure.sh
+ ./setup.sh
+}
+
+package() {
+ cd "$srcdir/${pkgname%-VCS}"
+ install -d "${pkgdir}"/opt/MolProbity "${pkgdir}"/usr/share/licenses/molprobity-git
+ cp -r * "${pkgdir}"/opt/MolProbity/.
+ cp LICENSE.html "${pkgdir}"/usr/share/licenses/molprobity-git/.
+}