summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2025-03-06 03:01:34 +0100
committerChristoph Haag2025-03-06 03:01:34 +0100
commit7328cd144ab1d27ccefb95e37b2b7500878e3410 (patch)
tree9fd450fb407efc4d576bd3d41b554cded6cc0139
parentae2fb225be3c7ba8b3c1846d534afecf0ae83912 (diff)
downloadaur-7328cd144ab1d27ccefb95e37b2b7500878e3410.tar.gz
misc updates
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1b4ba986957..85032226e7e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = monado-git
install = monado.install
arch = i686
arch = x86_64
- license = boost
+ license = BSL-1.0
makedepends = eigen
makedepends = ninja
makedepends = shaderc
@@ -21,17 +21,17 @@ pkgbase = monado-git
depends = libcap
depends = libbsd
depends = libdrm
- optdepends = libuvc: optical tracking support
- optdepends = opencv: optical tracking support
- optdepends = onnxruntime: optical hand tracking support
- optdepends = librealsense: intel realsense camera support
- optdepends = libsurvive-git: lighthouse positional tracking support
- optdepends = openhmd: additional hardware support (Oculus Rift, Nolo)
+ depends = openvr
+ optdepends = libuvc: optical tracking support (must be present at build time)
+ optdepends = opencv: optical tracking support (must be present at build time)
+ optdepends = onnxruntime: optical hand tracking support (must be present at build time)
+ optdepends = librealsense: intel realsense camera support (must be present at build time)
+ optdepends = libsurvive-git: lighthouse positional tracking support (must be present at build time)
+ optdepends = openhmd: additional hardware support (Oculus Rift, Nolo) (must be present at build time)
optdepends = basalt-monado-git: experimental SLAM tracking through basalt
- optdepends = kimera-vio-monado-git: experimental SLAM tracking through kimera
- optdepends = percetto: tracing support for performance debugging
+ optdepends = percetto: tracing support for performance debugging (must be present at build time)
provides = openxr-runtime
- provides = monado
+ provides = monado=24.0.0.r375.g4e22c990f
conflicts = monado
source = monado::git+https://gitlab.freedesktop.org/monado/monado.git#branch=main
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5f8980d8601b..bfa247ddd2d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,23 +7,22 @@ pkgrel=1
pkgdesc='The open source OpenXR runtime.'
arch=('i686' 'x86_64')
url='https://monado.dev'
-depends=('openxr' 'vulkan-icd-loader' 'libgl' 'wayland' 'xr-hardware' 'libcap' 'libbsd' 'libdrm')
+depends=('openxr' 'vulkan-icd-loader' 'libgl' 'wayland' 'xr-hardware' 'libcap' 'libbsd' 'libdrm' 'openvr')
conflicts=('monado')
#'doxygen' #When building docs
makedepends=('eigen' 'ninja' 'shaderc' 'cmake' 'git' 'vulkan-headers')
-optdepends=('libuvc: optical tracking support'
- 'opencv: optical tracking support'
- 'onnxruntime: optical hand tracking support'
- 'librealsense: intel realsense camera support'
- 'libsurvive-git: lighthouse positional tracking support'
- 'openhmd: additional hardware support (Oculus Rift, Nolo)'
+optdepends=('libuvc: optical tracking support (must be present at build time)'
+ 'opencv: optical tracking support (must be present at build time)'
+ 'onnxruntime: optical hand tracking support (must be present at build time)'
+ 'librealsense: intel realsense camera support (must be present at build time)'
+ 'libsurvive-git: lighthouse positional tracking support (must be present at build time)'
+ 'openhmd: additional hardware support (Oculus Rift, Nolo) (must be present at build time)'
'basalt-monado-git: experimental SLAM tracking through basalt'
- 'kimera-vio-monado-git: experimental SLAM tracking through kimera'
- 'percetto: tracing support for performance debugging')
-provides=("openxr-runtime" "monado")
+ 'percetto: tracing support for performance debugging (must be present at build time)')
+provides=("openxr-runtime" "monado=${pkgver}")
install=monado.install
-license=('boost')
+license=('BSL-1.0')
source=("$_dirname::git+https://gitlab.freedesktop.org/monado/monado.git#branch=main")
md5sums=('SKIP')