summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2021-09-20 13:44:54 +0200
committerChristoph Haag2021-09-20 13:46:22 +0200
commitb5e0faaa470ce45c7f04439b237c0748fc321eeb (patch)
treee0f8b6942bf87e0990bcea54ecf9b714f0b0fa1d
parent996e85e24af43bf3d5c241781ab176458198b084 (diff)
downloadaur-b5e0faaa470ce45c7f04439b237c0748fc321eeb.tar.gz
add install script to set nice cap
This enables the compositor to use a high priority vulkan queue.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--monado.install37
3 files changed, 43 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ff5d2cfae19..9af09b359c47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = monado-git
pkgdesc = The open source OpenXR runtime.
- pkgver = 21.0.0.r565.gb7b46908
+ pkgver = 21.0.0.r810.gd54c4897
pkgrel = 1
url = https://monado.dev
+ install = monado.install
arch = i686
arch = x86_64
license = boost
@@ -17,6 +18,7 @@ pkgbase = monado-git
depends = libgl
depends = wayland
depends = xr-hardware
+ depends = libcap
optdepends = libuvc: optical tracking support
optdepends = opencv: optical tracking support
provides = openxr-runtime
diff --git a/PKGBUILD b/PKGBUILD
index 626eca7124f2..9a6b7ad00b0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
pkgname="monado-git"
_dirname="monado"
-pkgver=21.0.0.r565.gb7b46908
+pkgver=21.0.0.r810.gd54c4897
pkgrel=1
pkgdesc='The open source OpenXR runtime.'
arch=('i686' 'x86_64')
url='https://monado.dev'
-depends=('openxr' 'openhmd' 'vulkan-icd-loader' 'libgl' 'wayland' 'xr-hardware')
+depends=('openxr' 'openhmd' 'vulkan-icd-loader' 'libgl' 'wayland' 'xr-hardware' 'libcap')
makedepends=('eigen' 'ninja' 'shaderc' 'meson' 'git')
optdepends=('libuvc: optical tracking support'
'opencv: optical tracking support')
provides=("openxr-runtime")
+install=monado.install
#'doxygen' #When building docs
makedepend=('cmake' 'eigen' 'git')
diff --git a/monado.install b/monado.install
new file mode 100644
index 000000000000..63e756ff7c5f
--- /dev/null
+++ b/monado.install
@@ -0,0 +1,37 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+post_install() {
+ echo "Running setcap cap_sys_nice+eip /usr/bin/monado-service"
+ setcap cap_sys_nice+eip /usr/bin/monado-service
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install "$1"
+}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}
+